Bug 1143190 - syslog-ng-3.19.1-3.3.aarch64: segfault at start
syslog-ng-3.19.1-3.3.aarch64: segfault at start
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: peter czanik
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-29 08:05 UTC by Matwey Kornilov
Modified: 2019-09-10 07:26 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
systemd-core (191.42 KB, application/octet-stream)
2019-07-29 08:05 UTC, Matwey Kornilov
Details
relevant debuginfo package (1.68 MB, application/x-rpm)
2019-07-29 08:07 UTC, Matwey Kornilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matwey Kornilov 2019-07-29 08:05:31 UTC
Created attachment 811889 [details]
systemd-core

Hello,

I am running syslog-ng-3.19.1-3.3.aarch64 at openSUSE Tumbleweed 20190724 and syslog service is crashing at the startup as following:

# systemctl status syslog
● syslog-ng.service - System Logging Service
   Loaded: loaded (/usr/lib/systemd/system/syslog-ng.service; enabled; vendor preset: disabled)
   Active: failed (Result: core-dump) since Tue 2019-05-28 12:58:57 MSK; 2 months 1 days ago
  Process: 1150 ExecStartPre=/usr/sbin/syslog-ng-service-prepare (code=exited, status=0/SUCCESS)
  Process: 1152 ExecStart=/usr/sbin/syslog-ng -F $SYSLOG_NG_PARAMS (code=dumped, signal=SEGV)
 Main PID: 1152 (code=dumped, signal=SEGV)

мая 28 12:58:57 localhost systemd[1]: syslog-ng.service: Service RestartSec=100ms expired, scheduling restart.
мая 28 12:58:57 localhost systemd[1]: syslog-ng.service: Scheduled restart job, restart counter is at 5.
мая 28 12:58:57 localhost systemd[1]: Stopped System Logging Service.
мая 28 12:58:57 localhost systemd[1]: syslog-ng.service: Start request repeated too quickly.
мая 28 12:58:57 localhost systemd[1]: syslog-ng.service: Failed with result 'core-dump'.
мая 28 12:58:57 localhost systemd[1]: Failed to start System Logging Service.
Comment 1 Matwey Kornilov 2019-07-29 08:07:29 UTC
Created attachment 811890 [details]
relevant debuginfo package
Comment 2 peter czanik 2019-07-30 18:33:34 UTC
I'm away from my ARM test machines on holiday. I hope to reproduce this next week. I remember having problems on Fedora Aarch64, but at the same time syslog-ng worked on openSUSE (but I'm not sure if I tested Leap or Tumbleweed...).

Please check my test repo: https://build.opensuse.org/project/show/home:czanik:syslog-ng-githead

If it works, I'll push 3.22 to Tumbleweed.
Comment 3 Matwey Kornilov 2019-07-30 19:52:06 UTC
Hi,

syslog-ng-3.22.1.50.g7ccb0ab-1.6.aarch64.rpm from your repo works fine.
Comment 4 peter czanik 2019-09-05 15:56:06 UTC
syslog-ng version 3.23.1 is now accepted to Factory, so it should be available in Tumbleweed soon:
https://build.opensuse.org/request/show/728145

The problem was in ivykis, the I/O library used by syslog-ng, and appeared only in Tumbleweed, not in Leap releases. Once the problem was fixed in ivykis, the bundled version was updated in syslog-ng. The latest release already uses that.
Comment 5 peter czanik 2019-09-10 07:26:01 UTC
Just tested, it works fine on my SoftIron OverDrive Aarch64 box.
Closing.