Bug 1143155 - OCFS2: o2locktop can not display the full hostname with python3
OCFS2: o2locktop can not display the full hostname with python3
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: High Availability
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Gang He
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-29 04:57 UTC by Gang He
Modified: 2019-08-19 16:18 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
cannot display the full hostname screen shot (175.37 KB, image/jpeg)
2019-07-29 04:58 UTC, Gang He
Details
display normally with python2 on Tumbleweed (183.22 KB, image/jpeg)
2019-07-29 04:59 UTC, Gang He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gang He 2019-07-29 04:57:12 UTC
o2locktop can work well with python2 on openSUSE Tumbleweed or SLE12/15, but o2locktop can not display the full hostname(only one node in the cluster) with python3. It looks Weikang did not test this program on python3, since the default python interpreter is always python2.
Comment 1 Gang He 2019-07-29 04:58:08 UTC
Created attachment 811864 [details]
cannot display the full hostname screen shot
Comment 2 Gang He 2019-07-29 04:59:13 UTC
Created attachment 811865 [details]
display normally with python2 on Tumbleweed
Comment 3 Swamp Workflow Management 2019-07-31 09:40:10 UTC
This is an autogenerated message for OBS integration:
This bug (1143155) was mentioned in
https://build.opensuse.org/request/show/720009 15.0 / o2locktop
https://build.opensuse.org/request/show/720010 15.1 / o2locktop
Comment 4 Swamp Workflow Management 2019-07-31 10:50:10 UTC
This is an autogenerated message for OBS integration:
This bug (1143155) was mentioned in
https://build.opensuse.org/request/show/720029 Backports:SLE-12-SP4 / o2locktop
Comment 5 Gang He 2019-08-01 03:08:11 UTC
The bug is fixed, close it.
Comment 6 Swamp Workflow Management 2019-08-19 16:18:51 UTC
openSUSE-RU-2019:1958-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1134390,1143155,1143159
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    o2locktop-1.0.10+git.1564463799.6f331ba-lp151.2.1
openSUSE Leap 15.0 (src):    o2locktop-1.0.10+git.1564463799.6f331ba-lp150.2.1