Bug 1143129 - Qt breaks libreoffice calc Alt+Drag
Qt breaks libreoffice calc Alt+Drag
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: LibreOffice
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Tomáš Chvátal
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-28 01:27 UTC by Geoffrey Fagan
Modified: 2019-10-14 10:25 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Fagan 2019-07-28 01:27:26 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Falkon/3.1.0 Chrome/73.0.3683.105 Safari/537.36
Build Identifier: 

LO uses drag'n'drop instead of cut'n'paste to move a row or column; default behavior leaves a hole at the source ond overwrites data at the destination but holding Alt changes the operation to cut from source and insert at destination. 

But under KDE, holding the Alt key does nothing. Turns out, if you remove package libreoffice-qt and install libreoffice-gnome, the Alt+Drag function works correctly, but then LO loses the benefits of Qt integration: It looks funny and opening a file from within the application fails to present directories at the top. 

Reproducible: Always

Steps to Reproduce:
1.Open libreoffice calc and populate some rows, say with numbers 1-4. 
2.Highlight row 2 by clicking on the left side. 
3.Click any part of the highlighted row and drag down a level, then release mouse button, to see default behavior. 
4.Repeat while holding Alt; actually, only need to hold Alt at moment of releasing mouse button. See that default behavior unchanged. 
5.Remove package libreoffice-qt, install package libreoffice-gnome, and repeat steps above. See the difference? 



Expected Results:  
Behavior would be consistent, Alt+Drag would work with libreoffice-qt installed just as it does with libreoffice-gnome. 

Tested on both Tumbleweed and live USB of Leap 15.1, same behavior on both. Note: Changing the modifier key for window acton in KDE system settings, from Alt to Meta, makes no difference. Tried with KDE themes openSUSE and Oxygen.
Comment 1 Christoph Feck 2019-07-29 01:37:25 UTC
kcmshell5 kwinoptions > Windows Actions tab > Modifier key
Comment 2 Geoffrey Fagan 2019-08-10 05:08:24 UTC
As I wrote in original report, changing the modifier key for window actions from Alt to Meta makes no difference to Calc's Alt+Drag, but let me add that even if it's unchanged, Alt+Drag works as long as libreoffice-qt isn't installed.
Comment 3 Walter Zimmer 2019-10-10 16:39:00 UTC
Just verified, with Leap 15.1 OSS libreoffile-qt5 version 6.2.7.1-lp151.3.6.1 the bug exists, solved by uninstalling just this package. Now I switched back my modified key to "Alt", still working as before. Looking forward to be able to install libreoffile-qt5 again. Tell us if you need more info.
Comment 4 Tomáš Chvátal 2019-10-14 10:25:42 UTC
This happens also with the upstream package. Sorry but SUSE does not have resources to play with the qt bindings and they are just taken directly from the upstream project.

If you observe issues there please report them to https://bugs.documentfoundation.org/ and we will be happy to take the patches and include them in our release.