Bug 1142901 - systemd-networkd: Could not bring up interface: Invalid argument
systemd-networkd: Could not bring up interface: Invalid argument
Status: RESOLVED DUPLICATE of bug 1142800
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
x86-64 Linux
: P5 - None : Normal (vote)
: ---
Assigned To: systemd maintainers
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-25 18:44 UTC by Marcel Kuehlhorn
Modified: 2019-07-29 07:53 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
# SYSTEMD_LOG_LEVEL=debug /usr/lib/systemd/systemd-networkd (8.04 KB, text/plain)
2019-07-25 18:44 UTC, Marcel Kuehlhorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Kuehlhorn 2019-07-25 18:44:50 UTC
Created attachment 811659 [details]
# SYSTEMD_LOG_LEVEL=debug /usr/lib/systemd/systemd-networkd

After updating to Tumbleweed snapshot 20190723 systemd-networkd fails to bring up my network interfaces.

<pre><code>
# journalctl -u systemd-networkd
-- Reboot --
Jul 25 19:30:22 tux93 systemd[1]: Starting Network Service...
Jul 25 19:30:22 tux93 systemd-networkd[1669]: Enumeration completed
Jul 25 19:30:22 tux93 systemd[1]: Started Network Service.
Jul 25 19:30:22 tux93 systemd-networkd[1669]: enp3s0: Interface name change detected, enp3s0 has been renamed to eth0.
Jul 25 19:30:22 tux93 systemd-networkd[1669]: eth0: Interface name change detected, eth0 has been renamed to enp3s0.
Jul 25 19:30:22 tux93 systemd-networkd[1669]: eno1: Interface name change detected, eno1 has been renamed to eth0.
Jul 25 19:30:22 tux93 systemd-networkd[1669]: eth0: Interface name change detected, eth0 has been renamed to eno1.
Jul 25 19:30:22 tux93 systemd-networkd[1669]: enp3s0: Could not bring up interface: Invalid argument
Jul 25 19:30:22 tux93 systemd-networkd[1669]: eno1: Could not bring up interface: Invalid argument
Jul 25 19:30:23 tux93 systemd-networkd[1669]: virbr0-nic: Gained carrier
Jul 25 19:30:23 tux93 systemd-networkd[1669]: virbr0-nic: Lost carrier
Jul 25 19:30:23 tux93 systemd-networkd[1669]: virbr0-nic: Removing non-existent address: fe80::5054:ff:fed2:befb/64 (valid forever), ignoring
</pre></code>

<pre><code>
# cat /etc/os-release
NAME="openSUSE Tumbleweed"
# VERSION="20190723"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20190723"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20190723"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
LOGO="distributor-logo"
</pre></code>
Comment 1 Benoît Monin 2019-07-25 19:29:39 UTC
I am facing the same issue with a bridge interface:
systemd-networkd[861]: br0: Could not bring up interface: Invalid argument

Manually bringing up the interface is enough to trigger networkd to configure it (e.g. ip link set up br0).
Comment 2 Bernhard Held 2019-07-26 06:09:16 UTC
Same here. The issue depends on the kernel version. 5.1.x is OK, with 5.2 and later networkd doesn't bring up my bridge interface.
Comment 3 Thomas Blume 2019-07-26 07:40:37 UTC
(In reply to Benoît Monin from comment #1)
> I am facing the same issue with a bridge interface:
> systemd-networkd[861]: br0: Could not bring up interface: Invalid argument
> 
> Manually bringing up the interface is enough to trigger networkd to
> configure it (e.g. ip link set up br0).

That looks like a duplicate of bug 1141597.
Comment 4 Thomas Blume 2019-07-26 07:55:55 UTC
Question is whether networkd is supposed to bring up the link layer vor virtual network interfaces.
Looking at comment#2 it seems that this is rather a task of the kernel driver.
Could someone from the kernel team please take a look?
Comment 5 Franck Bui 2019-07-26 08:05:57 UTC
(In reply to Bernhard Held from comment #2)
> Same here. The issue depends on the kernel version. 5.1.x is OK, with 5.2
> and later networkd doesn't bring up my bridge interface.

If the issue only appears with kernel 5.2, it sounds like boo#1142800
Comment 6 Franck Bui 2019-07-26 08:07:44 UTC
(In reply to Franck Bui from comment #5)
> If the issue only appears with kernel 5.2, it sounds like boo#1142800

I already submitted a fix for this one to Base:System.

You can give it a try here: https://build.opensuse.org/package/show/Base:System/systemd
Comment 7 Bernhard Held 2019-07-26 10:45:26 UTC
I confirm that my issue is solved with systemd-242-7.2.x86_64 from Base:System.

Thank you Franck for the package update!
Comment 8 Dominik Heidler 2019-07-26 12:42:45 UTC
(In reply to Thomas Blume from comment #4)
> Question is whether networkd is supposed to bring up the link layer vor
> virtual network interfaces.
> Looking at comment#2 it seems that this is rather a task of the kernel
> driver.
> Could someone from the kernel team please take a look?

For the record: It also happened one bare hardware (see my comment here: https://bugzilla.opensuse.org/show_bug.cgi?id=1141597#c9 )
Comment 9 Franck Bui 2019-07-26 12:53:28 UTC
Unfortunately it seems that kernel 5.2 has been released in TW before the networkd fix (available comment #6) was which lead to this bug.

Dominique do you confirm ?

If so can you please release a new version of systemd ASAP ?

Thanks.
Comment 10 Dominique Leuenberger 2019-07-27 13:28:19 UTC
(In reply to Franck Bui from comment #9)
> Unfortunately it seems that kernel 5.2 has been released in TW before the
> networkd fix (available comment #6) was which lead to this bug.
> 
> Dominique do you confirm ?
> 
> If so can you please release a new version of systemd ASAP ?

Snapshot 0726 has kernel 5.2.2 and systemd 242 (your latest submission, sr#718032)

The openQA tests fails nonetheless: https://openqa.opensuse.org/tests/993371#step/networkd_dhcp/31

(clearing needinfo for factory-auto in plus: the bot is shy and does not talk in bugs)
Comment 11 Marcel Kuehlhorn 2019-07-29 06:27:24 UTC
For me it is fixed with snapshot 20190726
Comment 12 Franck Bui 2019-07-29 07:21:21 UTC
(In reply to Dominique Leuenberger from comment #10)
> The openQA tests fails nonetheless:
> https://openqa.opensuse.org/tests/993371#step/networkd_dhcp/31

It's a different issue.
Comment 13 Franck Bui 2019-07-29 07:22:27 UTC
(In reply to Marcel Kuehlhorn from comment #11)
> For me it is fixed with snapshot 20190726

It's then a duplicate of boo#1142800

*** This bug has been marked as a duplicate of bug 1142800 ***