Bug 1142862 - Failed to load into multi-device Btrfs system installed with Autoyast
Failed to load into multi-device Btrfs system installed with Autoyast
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
Jiri Srain
https://openqa.opensuse.org/tests/989...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-25 13:46 UTC by Oleksandr Orlov
Modified: 2019-10-01 11:29 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
autoinst.xml (59.89 KB, text/xml)
2019-07-25 13:46 UTC, Oleksandr Orlov
Details
y2log (633.73 KB, application/gzip)
2019-07-25 13:48 UTC, Oleksandr Orlov
Details
error.png (82.70 KB, image/png)
2019-08-27 12:23 UTC, Oleksandr Orlov
Details
y2log from the installed system. (1.59 MB, application/x-xz)
2019-08-27 12:24 UTC, Oleksandr Orlov
Details
y2logs when error occurred during installation (95.43 KB, application/x-xz)
2019-08-27 12:24 UTC, Oleksandr Orlov
Details
autoinst.xml, Build20190824 (62.81 KB, text/xml)
2019-08-27 12:25 UTC, Oleksandr Orlov
Details
AutoYast profile TW-20190824 (62.87 KB, text/xml)
2019-08-28 13:27 UTC, David Diaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksandr Orlov 2019-07-25 13:46:16 UTC
Created attachment 811615 [details]
autoinst.xml

Steps to reproduce:

1. Install system with the attached autoinst.xml control file;
2. Boot to the installed system.

Expected result:
The system is loaded.
Actual result:
The system is not loaded. It is stuck on Tumbleweed splash screen.

NOTE: The control file was created with "yast2 clone_system" on the manually installed system, so the manually installed system was bootable.
Comment 1 Oleksandr Orlov 2019-07-25 13:48:51 UTC
Created attachment 811616 [details]
y2log
Comment 2 José Iván López González 2019-07-26 10:53:44 UTC
The exported control file looks wrong. It must contain a CT_BTRFS device, see [1]. Did you exported it from an updated Tumbleweed? Note that the exported system should use a modern TW to generate the autoins.xml with the correct options for multi-device Btrfs.

BTW, please, attach the whole logs, I mean, the tgz file generated by save_y2logs, see [2]. We need it to properly debug the problem. Thanks!

[1] https://github.com/yast/yast-storage-ng/pull/926

[2] https://en.opensuse.org/openSUSE:Report_a_YaST_bug
Comment 3 David Diaz 2019-08-26 16:33:11 UTC
Ping :)

Oleksandr, could you please provide the information required?

Thanks!
Comment 4 Oleksandr Orlov 2019-08-27 12:22:24 UTC
(In reply to David Diaz from comment #3)
> Ping :)
> 
> Oleksandr, could you please provide the information required?
> 
> Thanks!

Sorry for the late response.

The issue was observed on Build20190723. The system was installed from scratch, I didn't use any updates.

I've tried to replicate the problem on the latest TW Build20190824 and now I've got an error while starting installation with the generated autoinst.xml control file. The file was recently generated on Build20190824.

Steps to reproduce:

1. Run installation with 'autoyast2=<url to autoinst.xml>' boot parameter;
2. Focus on the installation wizard when presented with 'Perform Installation' step.

Expected result:
Installation started.
Actual result:
Error occurred. Please see 'error.png' screenshot.

Please see logs from the installed system, where the autoinst.xml was generated in the attached y2logs.tar.xz.

Please also see logs from the installation process when error is occurred in 'y2log-autoyast-install-error.tag.xz'
Comment 5 Oleksandr Orlov 2019-08-27 12:23:31 UTC
Created attachment 815856 [details]
error.png
Comment 6 Oleksandr Orlov 2019-08-27 12:24:07 UTC
Created attachment 815857 [details]
y2log from the installed system.
Comment 7 Oleksandr Orlov 2019-08-27 12:24:35 UTC
Created attachment 815858 [details]
y2logs when error occurred during installation
Comment 8 Oleksandr Orlov 2019-08-27 12:25:40 UTC
Created attachment 815859 [details]
autoinst.xml, Build20190824
Comment 9 Rodion Iafarov 2019-08-27 13:03:46 UTC
We have this issue on TW too: https://openqa.opensuse.org/tests/1018377#step/installation/43 where we have default installation with btrfs, no multidevice btrfs. Let us know if it makes sense to file separate bug for it, as it hides the one originally reported here.
Comment 10 David Diaz 2019-08-27 15:08:52 UTC
(In reply to Rodion Iafarov from comment #9)
> We have this issue on TW too:
> https://openqa.opensuse.org/tests/1018377#step/installation/43 where we have
> default installation with btrfs, no multidevice btrfs. Let us know if it
> makes sense to file separate bug for it, as it hides the one originally
> reported here.

Yes, please. It really looks as a different problem. Meanwhile, I'll try to reproduce the original one to have a bit more of information.

Thanks!
Comment 11 Rodion Iafarov 2019-08-28 07:04:21 UTC
(In reply to David Diaz from comment #10)
> (In reply to Rodion Iafarov from comment #9)
> > We have this issue on TW too:
> > https://openqa.opensuse.org/tests/1018377#step/installation/43 where we have
> > default installation with btrfs, no multidevice btrfs. Let us know if it
> > makes sense to file separate bug for it, as it hides the one originally
> > reported here.
> 
> Yes, please. It really looks as a different problem. Meanwhile, I'll try to
> reproduce the original one to have a bit more of information.
> 
> Thanks!

Here  it is: https://bugzilla.opensuse.org/show_bug.cgi?id=1148477 sorry for the delay.
Thanks a lot!
Comment 12 David Diaz 2019-08-28 13:26:16 UTC
Laying aside the second problem reported (which is already tracked in its report), I tried to reproduce the original one using a more recent TW (20190824) and the system is installed successfully. I mean, ignoring the UUID errors and simply going forward, the installer finish and the user can boot into the system.

So, I guess the problem was in the generated profile (I'll attach mine, also generated with TW 20190824).

Ivan, since you asked for information a few comments ago, what's your opinion?

Thanks!
Comment 13 David Diaz 2019-08-28 13:27:34 UTC
Created attachment 816038 [details]
AutoYast profile TW-20190824

AutoYast profile generated running `yast2 clone_system` in an openSUSE TW-20190824
Comment 14 David Diaz 2019-08-28 14:16:04 UTC
Oleksandr,

I already talked with Iván, who still think that the problem was in the first AutoYaST profile as the last works as expected. Likely, openSUSE TW 20190723 didn't have the right/fixed yast2-storage-ng version.

So, if you don't mind please try again with the latest TW build ignoring the "Setting UUID ..." warning. Just "Continue".

Thank you!
Comment 15 Joaquín Rivera 2019-10-01 08:53:21 UTC
I have created this bug, feel free to handle as you think is better, reopening this one and rejecting the other one or just continue in:
https://bugzilla.suse.com/show_bug.cgi?id=1152535
I attached there some screenshots for what happen after ignoring errors and trying to go forward in the installation.
Comment 16 José Iván López González 2019-10-01 11:29:59 UTC
I would continue with the new one [1] because the profile used here was wrong anyway.

[1] https://bugzilla.suse.com/show_bug.cgi?id=1152535