Bug 1142858 - Two TW selections is shown in GRUB after installing system with multi-device Btrfs
Two TW selections is shown in GRUB after installing system with multi-device ...
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Michael Chang
Jiri Srain
https://openqa.opensuse.org/tests/989...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-25 13:34 UTC by Oleksandr Orlov
Modified: 2020-11-30 13:20 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
partitioner setup (70.77 KB, image/png)
2019-07-25 13:34 UTC, Oleksandr Orlov
Details
two tw selections (10.65 KB, image/png)
2019-07-25 13:34 UTC, Oleksandr Orlov
Details
y2log (5.64 MB, text/plain)
2019-07-25 13:35 UTC, Oleksandr Orlov
Details
y2logs.tgz (1.88 MB, application/x-compressed-tar)
2019-08-13 12:47 UTC, Oleksandr Orlov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksandr Orlov 2019-07-25 13:34:23 UTC
Created attachment 811609 [details]
partitioner setup

Steps to reproduce:

1. Run Tumbleweed installer (e.g. Build20190723) on the system with 2 disks ;
2. Proceed to Expert Partitioner;
3. Add BIOS Boot partition (2mb) + unmounted Btrfs partition on the rest of the space of the 1st disk;
4. Add unmounted Btrfs partition on the 2nd disk;
5. Create multi-device Btrfs with the unmounted Btrfs partitions from the 1st and the 2nd disks (Please, see "partitioner-setup.png" screenshot for more details);
6. Finish the installation;
7. Focus on the GRUB menu when GRUB is appeared.

Expected result:
Only one Tumbleweed selection is shown.
Actual result:
Two Tumbleweed selections are shown. Please, see "grub-two-tumbleweed-selections.png" screenshot and y2log.
Comment 1 Oleksandr Orlov 2019-07-25 13:34:53 UTC
Created attachment 811610 [details]
two tw selections
Comment 2 Oleksandr Orlov 2019-07-25 13:35:13 UTC
Created attachment 811611 [details]
y2log
Comment 3 José Iván López González 2019-07-26 10:59:34 UTC
It looks like grub2 is wrongly detecting it. Reassigning it.

BTW, could you please attach the whole logs? Basically tgz file generated by save_y2logs, see [1]. This is quite useful for debugging the problem. 

Thanks for reporting!

[1] https://en.opensuse.org/openSUSE:Report_a_YaST_bug
Comment 4 Michael Chang 2019-08-13 09:12:22 UTC
Hi Oleksandr,

Would you please help to test the os-prober package in repository below ?

https://download.opensuse.org/repositories/home:/michael-chang:/branches:/Base:/System/openSUSE_Factory/

The duplicated distro entry is caused by the feature of btrfs multiple-device which can be mounted by specifying just one from the whole group, so that testing the disto through mounting separated btrfs block devices could be identical and thus duplicated in the result. The patch added the necessary uuid check when btrfs is mounted as root filesystem to make sure that different partition with same uuid will only be processed once to avoid such pitfalls.

Thanks.
Comment 5 Oleksandr Orlov 2019-08-13 12:46:54 UTC
Hi Michael,

I've tested Tumbleweed with the repo provided by you by passing 'self_update=https://download.opensuse.org/repositories/home:/michael-chang:/branches:/Base:/System/openSUSE_Factory/' to boot parameters, but I still got the same issue.

As asked in the previous comment, I'm attaching the y2logs.tgz. Please see them in the attached files.
Comment 6 Oleksandr Orlov 2019-08-13 12:47:13 UTC
Created attachment 813863 [details]
y2logs.tgz
Comment 7 Michael Chang 2019-08-15 09:52:29 UTC
(In reply to Oleksandr Orlov from comment #5)
> Hi Michael,
> 
> I've tested Tumbleweed with the repo provided by you by passing
> 'self_update=https://download.opensuse.org/repositories/home:/michael-chang:/
> branches:/Base:/System/openSUSE_Factory/' to boot parameters, but I still
> got the same issue.

Just checked with the YaST team, the self_update is used to update the installer itself (aka instsys, the initrd system running the installer) but NOT the target system to be installed. During the step of bootloader configuration is accomplished via chroot to the target system, the testing os-prober package has to be updated there.

So instead you have to use "addon=" to update os-prober package to the target system.

> addon=https://download.opensuse.org/repositories/home:/michael-chang:/branches:/Base:/System/openSUSE_Factory/

I have tested and it worked for me. Would you please help to verify again from your side ?

Thanks.
Comment 8 Oleksandr Orlov 2019-08-15 11:33:12 UTC
(In reply to Michael Chang from comment #7)
> (In reply to Oleksandr Orlov from comment #5)
> > Hi Michael,
> > 
> > I've tested Tumbleweed with the repo provided by you by passing
> > 'self_update=https://download.opensuse.org/repositories/home:/michael-chang:/
> > branches:/Base:/System/openSUSE_Factory/' to boot parameters, but I still
> > got the same issue.
> 
> Just checked with the YaST team, the self_update is used to update the
> installer itself (aka instsys, the initrd system running the installer) but
> NOT the target system to be installed. During the step of bootloader
> configuration is accomplished via chroot to the target system, the testing
> os-prober package has to be updated there.
> 
> So instead you have to use "addon=" to update os-prober package to the
> target system.
> 
> > addon=https://download.opensuse.org/repositories/home:/michael-chang:/branches:/Base:/System/openSUSE_Factory/
> 
> I have tested and it worked for me. Would you please help to verify again
> from your side ?
> 
> Thanks.

Hi Michael, thanks for the hint. 

I installed the last version of Tumbleweed with the provided boot parameter and it also works correctly for me. Only one Tumbleweed selection is shown, as expected.
Comment 9 Michael Chang 2019-08-27 10:20:05 UTC
Hi Oleksandr,

Thanks for your verification & confirmation. The patch was submitted to openSUSE:Factory by srid#726443 so change the resolution to fixed.
Comment 10 Oleksandr Orlov 2020-11-30 13:20:02 UTC
Verified. Fixed.