Bug 1142800 - systemd-networkd with kernel 5.2 don't up network interfaces
systemd-networkd with kernel 5.2 don't up network interfaces
Status: RESOLVED FIXED
: 1142901 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
All openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: Franck Bui
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-25 09:51 UTC by Илья Индиго
Modified: 2019-07-29 07:22 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
fbui: needinfo? (thomas.blume)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Илья Индиго 2019-07-25 09:51:56 UTC
The network is configured via systemd-networkd.
After update Tumbleweed to Kernel 5.2.1, I got a dead network.
At the same time, network and systemd-networkd are running and restarting them does not give anything.
The network is activated on only manually.
sudo ip link set enp3s0 up

If I updated remotely and restarted the computer, I would get a dead server.

Maybe openQA should add tests for systemd-netword?
Comment 1 Илья Индиго 2019-07-25 09:53:40 UTC
https://github.com/systemd/systemd/issues/12784
Comment 2 Илья Индиго 2019-07-25 12:17:09 UTC
SR https://build.opensuse.org/request/show/718032 fix network activation on startup.
Comment 3 Franck Bui 2019-07-25 12:51:17 UTC
Thanks for the report. As you already spotted, the fix has been submitted and should be part of the next update.

Hence closing.
Comment 4 Илья Индиго 2019-07-25 13:44:48 UTC
What about to prevent this in the future, and do QA tests for this?
Or does openQA test only what is by default, and those who use the systemd-netword do it at their own peril and risk?
Comment 5 Franck Bui 2019-07-25 13:58:23 UTC
Can you ask to upstream instead ?
Comment 6 Илья Индиго 2019-07-25 15:15:40 UTC
It’s useless to ask Lenard "Notabug" Pottering upstream, there are at least a dozen of such bugs.
As it seems to me, the distribution kit in its QA should be engaged in checking the basic operability of the distribution kit.
I do not know how openQA is organized here, and how and who to offer?
Not all in a row to ask dimstar by email.
Comment 7 Илья Индиго 2019-07-25 15:23:21 UTC
Moreover, I think that they even tested, but not with kernel 5.2, since they simply did not have it and could not do it.
Comment 8 Franck Bui 2019-07-25 15:27:57 UTC
Thomas, do you think this should worth to be check in openqa ?

IMO this should be checked by upstream so such issues are caught and fixed by them directly.
Comment 9 Franck Bui 2019-07-25 15:30:17 UTC
That said maybe it's already tested, it's just that kernel 5.2 has not yet been submitted and tested...

One more reason for upstream to test it I would say.
Comment 10 Franck Bui 2019-07-25 15:33:00 UTC
It looks like I missed your comment #7.
Comment 11 Dominik Heidler 2019-07-26 13:30:49 UTC
(In reply to Franck Bui from comment #8)
> Thomas, do you think this should worth to be check in openqa ?
> 
> IMO this should be checked by upstream so such issues are caught and fixed
> by them directly.

This actually made openQA tests fail: https://bugzilla.opensuse.org/show_bug.cgi?id=1141597
https://openqa.opensuse.org/tests/990747
Comment 12 Franck Bui 2019-07-26 15:08:21 UTC
(In reply to Dominik Heidler from comment #11)
> This actually made openQA tests fail:
> https://bugzilla.opensuse.org/show_bug.cgi?id=1141597
> https://openqa.opensuse.org/tests/990747

Nope, again this one is a different issue.
Comment 13 Franck Bui 2019-07-29 07:22:27 UTC
*** Bug 1142901 has been marked as a duplicate of this bug. ***