Bug 1142670 - LLADDR in bridge configuration ignored.
LLADDR in bridge configuration ignored.
Status: RESOLVED DUPLICATE of bug 1042123
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
All Other
: P2 - High : Normal (vote)
: ---
Assigned To: wicked maintainers
E-mail List
:
Depends on: 1042123
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-24 14:36 UTC by Nick Singer
Modified: 2020-03-23 13:12 UTC (History)
10 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Singer 2019-07-24 14:36:00 UTC
+++ This bug was initially created as a clone of Bug #1042123 +++

I've a simple network setup for my local workstation. I physical interface belonging to a bridge. To receive the same IP from DHCP I tried to change the mac of the physical interface to something (random) and the mac of the bridge to the initial mac of the physical interface. I've two ifcfgs for that:

```
root@1a251:/etc/sysconfig/network # cat ifcfg-p3p1
# Original config
#BOOTPROTO='dhcp'
#STARTMODE='auto'
#ZONE=public
#HWADDR=b4:96:91:16:bb:e6 <- this is the burnt in mac of the physical interface
LLADDR=68:05:ca:2f:c7:87
BOOTPROTO='none'
NETMASK=''
STARTMODE='auto'
BRIDGE=br0
ZONE=public
```

```
root@1a251:/etc/sysconfig/network # cat ifcfg-br0
BOOTPROTO='dhcp'
BRIDGE='yes'
LLADDR=b4:96:91:16:bb:e6
BRIDGE_FORWARDDELAY='0'
BRIDGE_PORTS='p3p1'
BRIDGE_STP='off'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
ZONE=public
```

after restarting the network/wicked the interfaces look like this:

```
2: p3p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br0 state UP group default qlen 1000
    link/ether 68:05:ca:2f:c7:87 brd ff:ff:ff:ff:ff:ff
13: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 8a:5c:dd:d0:92:b7 brd ff:ff:ff:ff:ff:ff
    […snip…]
```

As you can see: p3p1 has the correct mac, br0 just got ignored. There is nothing at all in my systems journal.

I remember that this worked in the past with the option "HWADDR" but stopped working after some update (guess the option got deprecated).

According to `man 5 ifcfg`, this should work: "LLADDR Set an individual link layer address (MAC address)."
Comment 1 Marius Tomaschewski 2019-07-26 13:43:06 UTC
(In reply to Nick Singer from comment #0)
> +++ This bug was initially created as a clone of Bug #1042123 +++
> I remember that this worked in the past with the option "HWADDR" but stopped
> working after some update (guess the option got deprecated).

No, it was always the LLADDR variable to set it on SUSE systems (sysconfig,
wicked) and never HWADDR :-)

> According to `man 5 ifcfg`, this should work: "LLADDR Set an individual link
> layer address (MAC address)."

Yes, that's true. We've missed to consider it, but now I just did, see:

https://github.com/openSUSE/wicked/pull/803

Test RPM you can find in:
https://download.opensuse.org/repositories/network:/wicked:/testing/
Comment 2 Marius Tomaschewski 2019-07-26 13:49:32 UTC
AFAIR a historical note: at least old kernels reset it to a mac of a port...
Comment 3 Swamp Workflow Management 2019-08-14 18:30:39 UTC
This is an autogenerated message for OBS integration:
This bug (1142670) was mentioned in
https://build.opensuse.org/request/show/723357 Factory / wicked
Comment 9 Swamp Workflow Management 2019-10-11 19:12:57 UTC
SUSE-RU-2019:2636-1: An update that has 8 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129986,1132280,1132326,1132774,1136034,1140117,1142670
CVE References: 
Sources used:
SUSE CaaS Platform 3.0 (src):    wicked-0.6.55-38.19.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 15 Swamp Workflow Management 2019-11-29 14:13:33 UTC
SUSE-RU-2019:3112-1: An update that has 13 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129986,1132280,1132326,1132774,1132977,1136034,1140117,1142214,1142670,1143182,1150183,1150972
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP4 (src):    wicked-0.6.60-2.13.2
SUSE Linux Enterprise Desktop 12-SP4 (src):    wicked-0.6.60-2.13.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 16 Swamp Workflow Management 2019-11-29 14:17:17 UTC
SUSE-RU-2019:3114-1: An update that has 14 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129631,1129986,1132280,1132326,1132774,1132977,1136034,1140117,1142214,1142670,1143182,1150183,1150972
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15 (src):    wicked-0.6.60-3.18.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 17 Swamp Workflow Management 2019-11-29 17:14:40 UTC
SUSE-RU-2019:3124-1: An update that has 13 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129986,1132280,1132326,1132774,1132977,1136034,1140117,1142214,1142670,1143182,1150183,1150972
CVE References: 
Sources used:
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    wicked-0.6.60-28.22.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    wicked-0.6.60-28.22.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 18 Swamp Workflow Management 2019-11-29 17:17:54 UTC
SUSE-RU-2019:3123-1: An update that has 13 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129986,1132280,1132326,1132774,1132977,1136034,1140117,1142214,1142670,1143182,1150183,1150972
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    wicked-0.6.60-3.7.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 19 Swamp Workflow Management 2019-12-03 23:20:53 UTC
openSUSE-RU-2019:2617-1: An update that has 14 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129631,1129986,1132280,1132326,1132774,1132977,1136034,1140117,1142214,1142670,1143182,1150183,1150972
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    wicked-0.6.60-lp150.2.13.1
Comment 20 Swamp Workflow Management 2019-12-04 23:13:35 UTC
openSUSE-RU-2019:2643-1: An update that has 13 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042123,1129986,1132280,1132326,1132774,1132977,1136034,1140117,1142214,1142670,1143182,1150183,1150972
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    wicked-0.6.60-lp151.2.3.1
Comment 21 Christian Wittmer 2020-01-05 15:10:27 UTC
with latest update e.g. on Leap 15.1 to wicked-0.6.60-lp151.2.3.1 now 'bridge' interface is not getting started, when LLADDR is defined in ifcfg-bridge

sys-01:/etc/sysconfig/network # cat ifcfg-brint 
BOOTPROTO='static'
BRIDGE='yes'
BRIDGE_FORWARDDELAY='0'
BRIDGE_PORTS=''
BRIDGE_STP='off'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='192.168.141.1/24'
LLADDR='52:54:00:a8:8d:01'
MTU=''
NAME=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'

sys-01:~ # ifdown brint
--- snip /var/log/messages ---
2020-01-05T14:56:12.278787+00:00 sys-01 named[2849]: no longer listening on 192.168.141.1#53
2020-01-05T14:56:12.525767+00:00 sys-01 dhcpd: receive_packet failed on brint: Network is down
--- snip /var/log/messages ---

sys-01:~ # ifup brint
brint           setup-in-progress
--- snip /var/log/messages ---
2020-01-05T14:56:50.298370+00:00 sys-01 systemd-udevd[18160]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
2020-01-05T14:56:50.298638+00:00 sys-01 systemd-udevd[18160]: Could not generate persistent MAC address for brint: No such file or directory
2020-01-05T14:56:50.314146+00:00 sys-01 kernel: [  468.992201] IPv6: ADDRCONF(NETDEV_UP): brint: link is not ready
--- snip /var/log/messages ---

without LLADDR it works.
Comment 22 Marius Tomaschewski 2020-03-23 13:12:00 UTC
This is a kernel / bridge specific behavious and wicked does not have anything in common with wicked. See https://bugzilla.suse.com/show_bug.cgi?id=1042123#c33

*** This bug has been marked as a duplicate of bug 1042123 ***