Bug 1142669 - [multi-device Btrfs] Internal error occurred while moving used btrfs device from the list of selected devices
[multi-device Btrfs] Internal error occurred while moving used btrfs device f...
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://openqa.opensuse.org/tests/989...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-24 14:31 UTC by Oleksandr Orlov
Modified: 2020-11-30 13:36 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
multiple-btrfs-yast-error.png (106.06 KB, image/png)
2019-07-24 14:31 UTC, Oleksandr Orlov
Details
y2logs (1018.86 KB, text/plain)
2019-07-24 14:32 UTC, Oleksandr Orlov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksandr Orlov 2019-07-24 14:31:50 UTC
Created attachment 811453 [details]
multiple-btrfs-yast-error.png

Affected version: Tumbleweed [Build 20190723] 

Steps to reproduce:

1. Start installation of Tumbleweed (Build 20190723) for system with at least 2 disks;
2. Proceed to Expert Partitioner Step;
3. Format any disk with Btrfs and mount to "/";
4. Select "Btrfs" in System View;
5. Select "Modify" -> "Change Used Devices...";
6. Click "Remove All" button to move recently formatted btrfs partition back to Available Devices list.

Expected result:
The device is moved to "Available Devices" list. No errors occurred.
Actual result:
Internal error occurred. Please see "multiple-btrfs-yast-error.png" screenshot and y2logs for the details.
Comment 1 Oleksandr Orlov 2019-07-24 14:32:25 UTC
Created attachment 811454 [details]
y2logs
Comment 3 Arvin Schnell 2019-07-29 09:09:41 UTC
It looks as if this is caused by the BlkDeviceRestorer trying to restore the
Btrfs itself on one of the block devices.
Comment 4 Arvin Schnell 2019-07-30 09:03:19 UTC
PR: https://github.com/yast/yast-storage-ng/pull/948
Comment 5 Arvin Schnell 2019-07-30 09:27:46 UTC
Fixed by PR mentioned above.
Comment 6 Oleksandr Orlov 2020-11-30 13:36:14 UTC
Verified. Fixed.