Bug 1142587 - "use_lvmetad = 1" delays shutdown / reboot for about 2 minutes
"use_lvmetad = 1" delays shutdown / reboot for about 2 minutes
Status: RESOLVED DUPLICATE of bug 1096241
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: heming zhao
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-24 07:57 UTC by robert spitzenpfeil
Modified: 2019-11-06 03:14 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description robert spitzenpfeil 2019-07-24 07:57:31 UTC
The default setting "use_lvmetad = 1" in /etc/lvm/lvm.conf delays shutdown / reboot by about 2 minutes - most of the time, not always.

Setting it to "0" solves the delay issue for me 100%.

Please let me know what info / logfiles you need to get to the bottom of this.

The behaviour sounds very similar to this bug, which was files against a TW release of 2018.

https://bugzilla.opensuse.org/show_bug.cgi?id=1096241
Comment 1 robert spitzenpfeil 2019-08-10 22:31:53 UTC
Still an issue with "kernel-default-5.2.5-1.2.x86_64"
Comment 2 heming zhao 2019-11-06 03:14:13 UTC
Hello 

bug #1096241 (tb), bug #1129476 (leap15.1), bug #1142587 (tb)& bug #1155668 (sles15sp1) are same. 

I will close bug:
1096241 "resolved->fix" <== just mark as fix
1129476 "resolved->dup->1096241"
1142587 "resolved->dup->1096241"
1155668 "resolved->fix" <== use this bug No to fix

Opensuse leap15.1 will auto backport from sles15sp1. Please wait.
Opensuse tumbleweed lvm2 version is 2.3.05+, which has already contained these patches. So it doesn't need to fix.

Thanks.

*** This bug has been marked as a duplicate of bug 1096241 ***