Bug 1142530 - libICE6 >=1.0.10 blocks KDE3 and TDE sessions from starting
libICE6 >=1.0.10 blocks KDE3 and TDE sessions from starting
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
Other Other
: P3 - Medium : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
https://gitlab.freedesktop.org/xorg/l...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-23 15:46 UTC by Felix Miata
Modified: 2019-11-19 04:17 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2019-07-23 15:46:47 UTC
Original Summary:
libICE6 >1.0.9-4.7 blocks KDE3 and TDE sessions from starting

Mailing list threads:
https://lists.opensuse.org/opensuse-kde3/2019-07/msg00012.html
http://trinity-users.pearsoncomputing.net/?0::15841

Try to start KDE3 session after upgrade to libICE6-1.0.10-1.1:
[quote]
There was an error setting up inter-process communications for KDE. The message
returned by the system was:

Could not read network connection list:
/root/.DCOPserver_gx27c_0

Please check that the  "dcopserver" program is running.
[/quote]

Reverting to libICE6-1.0.9-4.7 on host gx27c via rpmrebuild on host gx280 restored access to a working KDE3 session.
Comment 1 Stefan Dirsch 2019-07-24 12:47:22 UTC
It would be good if somebody could bisect this. Just 31 commits between 1.0.9 and 1.0.10.
Comment 2 Stefan Dirsch 2019-07-24 12:48:24 UTC
(about 5 steps only)
Comment 3 Stefan Dirsch 2019-07-24 12:48:59 UTC
--> git://anongit.freedesktop.org/git/xorg/lib/libICE
Comment 4 Felix Miata 2019-07-24 15:24:04 UTC
I filed this upstream since it also affects TDE on Archlinux.
Comment 5 Stefan Dirsch 2019-07-24 15:31:24 UTC
(In reply to Felix Miata from comment #4)
> I filed this upstream since it also affects TDE on Archlinux.

Thanks.  Looks like the culprit is

http://trinity-users.pearsoncomputing.net/?0::15847

commit b484311c929a1b64966d89da92fafce7263006e1
Author: Allison Lortie <desrt@desrt.ca>
Date:   Tue Jun 14 16:09:46 2016 -0400

    authutil: support $XDG_RUNTIME_DIR/ICEauthority
    
    If we find that $XDG_RUNTIME_DIR is set (and $ICEAUTHORITY is not), then
    the ICEauthority file is stored in the XDG_RUNTIME_DIR instead of the
    home directory, and without a leading dot.
    
    https://bugs.freedesktop.org/show_bug.cgi?id=49173
    Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Comment 6 Felix Miata 2019-07-24 16:13:55 UTC
(In reply to Stefan Dirsch from comment #5)
> commit b484311c929a1b64966d89da92fafce7263006e1

https://cgit.freedesktop.org/xorg/lib/libICE/commit/?id=b484311c92 referenced by TDE bug.
Comment 7 Felix Miata 2019-07-25 03:22:04 UTC
I  just updated TW20190614 to TW20190723 with libICE6-1.0.9-4.7 to libICE6-1.0.10-1.1 on  host fi965r without remembering to first lock 1.0.09-4.7, and this bug did not present either via KDM3 or startx. :-O

Earlier in the  day it did present on another 64bit host (gx320?) upgraded from TW20190514(?) to TW20190721 with libICE6-1.0.9-4.5 locked. :-S
Comment 8 Felix Miata 2019-07-29 00:06:51 UTC
On TW20190607 host t2240 with libICE6-1.0.9-4.6 I locked it before upgrading to TW20190726. Rebooting resulted in blocked KDE3 session, for same reason. so I unlocked libICE6, upgraded it to 1.0.10, restarted KDM, and was immediately able to log into a KDE3 session normally, as well as on subsequent boot.
Comment 9 Stefan Dirsch 2019-07-29 09:05:48 UTC
So what's the remaining issue here? Our users usually don't block updates, right? Apart from KDE3/TDE not being shipped, let alone being supported by TW anyway ...
Comment 10 Stefan Dirsch 2019-08-23 13:52:31 UTC
Ok. So seems nothing remains here. Otherwise please feel free to reopen (with a good reason!).  ;-)
Comment 11 Felix Miata 2019-11-16 23:46:54 UTC
I just zypper dup'd 64bit host gx620 from TW20190716 to TW20191112, which upgraded libICE6-1.0.9-4.8 to libICE6-1.0.10-1.1, which in turn resurrected this bug in TDE. I kept 1.0.9-4.7, which I reinstalled to work around this.
Comment 12 Stefan Dirsch 2019-11-18 13:59:26 UTC
So is there $XDG_RUNTIME_DIR or $ICEAUTHORITY set during desktop start? Does $XDG_RUNTIME_DIR/ICEauthority or $HOME/.ICEauthority exist?
Comment 13 Felix Miata 2019-11-18 19:03:49 UTC
My reading of the corresponding TDE bug http://bugs.pearsoncomputing.net/show_bug.cgi?id=3027 suggests it may be that a TDE patch is required.

Successfully booted into a TDE session because older libICE is installed:
# echo $HOSTNAME
gx620
# rpm -qa | grep libICE
libICE6-1.0.9-4.7.x86_64
# echo $XDG_RUNTIME_DIR
/run/user/0
# echo $ICEAUTHORITY

# echo $XDG_RUNTIME_DIR/IDEauthority
/run/user/0/IDEauthority
# echo $HOME/.ICEauthority
/root/.ICEauthority
Comment 14 Stefan Dirsch 2019-11-19 03:38:59 UTC
Could well be. I suggest to use the workaround referenced in http://bugs.pearsoncomputing.net/show_bug.cgi?id=3027#c2
http://trinity-users.pearsoncomputing.net/?0::15847
Comment 15 Stefan Dirsch 2019-11-19 04:17:04 UTC
I believe the issue is in DCOP not using libice, but hardcode ICEAUTHORITY file instead.

http://bugs.pearsoncomputing.net/show_bug.cgi?id=3044

explains how to fix this using libice. I wasn't able to find dcop, let alone the sources for it. Probably this died together with KDE3.

https://en.wikipedia.org/wiki/DCOP