Bug 1142498 - Cobbler System add fails without explicit usage of redhat_management_key
Cobbler System add fails without explicit usage of redhat_management_key
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
Other All
: P2 - High : Normal (vote)
: ---
Assigned To: Mihai Dincă
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-23 11:30 UTC by Enno Gotthold
Modified: 2019-09-03 13:05 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Screenshot Cobbler-CLI-Error (38.77 KB, image/png)
2019-07-23 11:30 UTC, Enno Gotthold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Enno Gotthold 2019-07-23 11:30:10 UTC
Created attachment 811302 [details]
Screenshot Cobbler-CLI-Error

Steps to reproduce
1. Install cobbler 3.0.0-400.25.8.develHead (current version shipped with SUMA I think)
2. Import a Distro via cobbler import --name=NAME --arch=x86_64 --path=YOURPATHHERE
3. Add a profile via cobbler profile add --name=NAME --distro=NAMEOFDISTRO
4. Add a system via cobbler system add --name=SYSTEMNAME --hostname=HOSTNAME --profile=PROFILENAME

Now get from the CLI a Stacktrace which is attached to the Bug. The cobbler log has no content related to that because the cli is not even sending the system add.
Comment 1 Pablo Suárez Hernández 2019-07-23 11:36:37 UTC
Also affecting Cobbler version released in SUMA.
Comment 2 Mihai Dincă 2019-09-03 13:05:00 UTC
Fixed: https://github.com/SUSE/spacewalk/issues/8520