Bug 1142448 - libqt5-qtwebengine symbol lookup error - applications fail to start
libqt5-qtwebengine symbol lookup error - applications fail to start
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-23 07:17 UTC by X Y
Modified: 2019-07-23 07:58 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
wbauer: needinfo? (tx872yz339)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description X Y 2019-07-23 07:17:31 UTC
Trying to start an application relying on libqt5-qtwebengine (like kontact/kmail or ksysguard) fails with the following error:

symbol lookup error: /usr/lib64/libQt5WebEngineCore.so.5: undefined symbol: FT_Palette_Select

I first encountered this after updating to TW 20190718, but I was away from home for all of July, so it could have been introduced in any release between Jul 1st and the release mentioned.
It is also still present in TW 20190721.

It is NOT present in the KDE factory packages.
Comment 1 Wolfgang Bauer 2019-07-23 07:45:07 UTC
By chance I'm currently booted into the latest Tumbleweed LiveCD (20190721), and QtWebEngine happens to work fine.

So this is likely caused by an incomplete upgrade or mixing incompatible repos/packages.

Please show the output of "zypper lr -d", and the exact versions of libqt5-qtwebengine and libfreetype installed:
rpm -qi libqt5-qtwebengine
rpm -qi libfreetype6
Comment 2 X Y 2019-07-23 07:58:57 UTC
(In reply to Wolfgang Bauer from comment #1)
> By chance I'm currently booted into the latest Tumbleweed LiveCD (20190721),
> and QtWebEngine happens to work fine.
> 
> So this is likely caused by an incomplete upgrade or mixing incompatible
> repos/packages.

You were right, it was caused by a libfreetype6 package I still had installed from another repo - I don't even remember why exactly.

Good catch, clear case of PEBKAC.