Bug 1142018 - sqlite3 fails in %check assertion on armv7/armv6
sqlite3 fails in %check assertion on armv7/armv6
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
armv7 Linux
: P5 - None : Normal (vote)
: ---
Assigned To: Reinhard Max
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-18 11:37 UTC by Guillaume GARDET
Modified: 2021-09-14 11:29 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume GARDET 2019-07-18 11:37:11 UTC
The error is:

[ 1020s] SQLite 3.29.0 2019-07-10 17:32:03 fc82b73eaac8b36950e527f12c4b5dc1e147e6f4ad2217ae43ad82882a88bfa6
[ 1020s] ./sessionfuzz run /home/abuild/rpmbuild/BUILD/sqlite-src-3290000/test/sessionfuzz-data1.db
[ 1020s] sessionfuzz-data1.db: sessionfuzz: ./sqlite3.c:56432: pager_open_journal: Assertion `rc!=SQLITE_OK || isOpen(pPager->jfd)' failed.
[ 1020s] make: *** [Makefile:1248: fastfuzztest] Aborted
[ 1020s] make: *** Waiting for unfinished jobs....

Latest build logs:
* armv7: https://build.opensuse.org/package/live_build_log/openSUSE:Factory:ARM/sqlite3/standard/armv7l
* armv6: https://build.opensuse.org/package/live_build_log/openSUSE:Factory:ARM/sqlite3/standard/armv6l

Same bug happens on gentoo, sparc64 https://bugs.gentoo.org/685874
Comment 1 Guillaume GARDET 2019-12-16 13:51:56 UTC
Max, any update here?
Comment 2 Reinhard Max 2019-12-16 14:34:16 UTC
I didn't get to look into it myself yet, but just made upstream aware of it, given that the Gentoo report says that it still happens with the latest version of SQLite.
Comment 3 Reinhard Max 2019-12-19 09:57:39 UTC
They have difficulties to reproduce the assertion failure and we're now comparing their setup to ours to find the relevant differences.
Comment 4 Reinhard Max 2021-09-14 11:29:47 UTC
According to the Gentoo bug linked above this got fixed in or before version 3.32.3, which we've had in TW since June 2020.
Therefore I am closing this, but feel free to reopen if you still see it happen.