Bug 1141963 - When starting YaST2 - Installation server, error reported as "Uninitialized Constant"
When starting YaST2 - Installation server, error reported as "Uninitialized C...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: David Diaz
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-18 07:22 UTC by Mark Smith
Modified: 2019-08-31 22:47 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Smith 2019-07-18 07:22:35 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0
Build Identifier: 

While using Yast2 to Start the Installation Server to configure (YaST > Miscellaneous > Installation Server), YaST2 - Installation Server screen is displayed and starts to "Initialising Configuration".  When reading the Configuration file, an Error box is displayed with the following, 

"Internal error. Please report a bug report with logs.
Run save_y2logs to get complete logs.

Caller: /usr/share/YaST2/modules/Instserver.rb:1007:in `NFSValid'

Details: uninitialized constant Yast::InstserverClass::NFS_SERVER_SERVICE
Did you mean? Yast::InstserverClass::NFS_SERVER_SEVICE"



Reproducible: Always

Steps to Reproduce:
Providing the Installation Server is installed
1.Start the YaST2 Control Center
2.Select Miscellaneous
3.Select Installation Server

Actual Results:  
Installation Server windows will show and while reading configuration file it will display the error

Expected Results:  
Installation server should start and allow you to select a repository type (HTTP, FTP, NFS) and configure.

I think that it is a miss-spelling of "SERVICE" as the "Did you Mean" has the R missing.

Selecting OK, closes the error window and puts you back to the desktop.

I have the completed save_y2logs if you require the log.

AME="openSUSE Tumbleweed"
# VERSION="20190716"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20190716"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20190716"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
LOGO="distributor-logo"
Comment 1 Mark Smith 2019-07-18 08:25:26 UTC
Found a fix, Line 17 in /usr/share/YaST2/modules/Instserver.rb, shows:-

"NFS_SERVER_SEVICE" Needs changing to NFS_SERVER_SERVICE ('R' missing in Service)

Have changed on my system and seems to be working now.
Comment 3 David Diaz 2019-07-19 07:11:28 UTC
Hi Mark, 

Thanks for the report.

Exactly, the problem was there. We were working on it, but we couldn't submit the changes until now.

So, the module will work as expected for 

- yast2-instserver >= 4.1.6 (SLE-15-SP1)
  * https://github.com/yast/yast-instserver/pull/43
  * https://build.suse.de/request/show/197024

- yast2-instserver >= 4.2.2 (SLE-15-SP2)
  * https://github.com/yast/yast-instserver/pull/44
  * https://github.com/yast/yast-instserver/pull/45
  * https://build.opensuse.org/request/show/716728
Comment 4 Swamp Workflow Management 2019-08-21 13:18:37 UTC
SUSE-RU-2019:2186-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1141963
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    yast2-instserver-4.1.6-13.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2019-08-31 16:12:23 UTC
openSUSE-RU-2019:2029-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1141963
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    yast2-instserver-4.1.6-lp151.2.3.1