Bug 1141947 - Failed to initialize glamor: modesetting DDX works during TW installation but not in installed system on i945G 8086:2772 GMA 950 & iG33 8086:29c2 GMA 3100
Failed to initialize glamor: modesetting DDX works during TW installation but...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-18 05:39 UTC by Felix Miata
Modified: 2019-07-18 14:01 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2logs saved after two mouse clicks in TW20190716 installer on i945G host gx620 (434.56 KB, application/octet-stream)
2019-07-18 05:39 UTC, Felix Miata
Details
Xorg.0.log from installed TW20190716 host gx620 (10.66 KB, text/plain)
2019-07-18 05:41 UTC, Felix Miata
Details
Xorg.0.log from TW20190716 installer on host gx620 (24.62 KB, text/plain)
2019-07-18 05:42 UTC, Felix Miata
Details
Xorg.0.log from host gx62b after purging Mesa-dri (24.41 KB, text/plain)
2019-07-18 12:34 UTC, Felix Miata
Details
Xorg.0.log with Mesa-dri restored and using Option "AccelMethod" "none" (21.98 KB, text/plain)
2019-07-18 13:11 UTC, Felix Miata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2019-07-18 05:39:56 UTC
Created attachment 810797 [details]
y2logs saved after two mouse clicks in TW20190716 installer on i945G host gx620

Initial summary:
Failed to initialize glamor: modesetting DDX works during TW installation but not in installed system on i945G 8086:2772 GMA 950 & iG33 8086:29c2 GMA 3100

This failure exists also in 15.0 and 15.1.

To reproduce, either have xf86-video-intel not installed, or configure modesetting explicitly, e.g. /etc/X11/xorg.conf.d/50-device.conf containing:
Section "Device"
	Identifier "Default Device"
	Driver "modesetting"
EndSection

Portion of tail of Xorg.0.log on installed TW20190716 host gx620:
[   197.751] Require OpenGL version 2.1 or later.
[   197.751] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
[   197.751] (EE) 
Fatal server error:
[   197.752] (EE) AddScreen/ScreenInit failed for driver 0
Comment 1 Felix Miata 2019-07-18 05:41:32 UTC
Created attachment 810798 [details]
Xorg.0.log from installed TW20190716 host gx620
Comment 2 Felix Miata 2019-07-18 05:42:45 UTC
Created attachment 810799 [details]
Xorg.0.log from TW20190716 installer on host gx620
Comment 3 Stefan Dirsch 2019-07-18 06:52:14 UTC
Ok. On the installed system try again after un installing Mesa-dri package.
Comment 4 Stefan Dirsch 2019-07-18 06:53:01 UTC
*uninstalling*
Comment 5 Felix Miata 2019-07-18 07:15:02 UTC
# zypper rm Mesa-dri
Loading repository data...
Warning: No repositories defined. Operating only with the installed resolvables. Nothing can be installed.
Reading installed packages...
Resolving package dependencies...

The following 16 packages are going to be REMOVED:
  Mesa Mesa-dri Mesa-gallium Mesa-libGL1 patterns-base-x11 xf86-input-evdev xf86-input-keyboard xf86-input-libinput xf86-input-mouse
  xf86-input-void xf86-video-amdgpu xf86-video-fbdev xf86-video-intel xf86-video-vesa xorg-x11-driver-video xorg-x11-server

The following pattern is going to be REMOVED:
  x11

16 packages to remove.
After the operation, 47.7 MiB will be freed.
Continue? [y/n/v/...? shows all options] (y): n

Should I try uninstalling via rpm -e --nodeps?
Comment 6 Stefan Dirsch 2019-07-18 09:06:42 UTC
Yes, please use

  rpm -e --nodeps Mesa-dri

It's just for testing purposes ...
Comment 7 Felix Miata 2019-07-18 11:41:45 UTC
With Mesa-dri removed:
# inxi -GxxSM
System:    Host: gx62b Kernel: 5.1.16-1-default x86_64 bits: 64 compiler: gcc v: 9.1.1 
           parameters: root=LABEL=17ostw ipv6.disable=1 net.ifnames=0 noresume mitigations=auto consoleblank=0 vga=791 
           video=1440x900@60 3 drm.debug=0x1e log_buf_len=1M 
           Desktop: KDE Plasma 5.16.0 tk: Qt 5.12.3 wm: kwin_x11 dm: startx Distro: openSUSE Tumbleweed 20190716 
Machine:   Type: Desktop System: Dell product: OptiPlex GX620 v: N/A serial: DQ7Q891 Chassis: type: 15 serial: DQ7Q891 
           Mobo: Dell model: 0F8101 serial: ..CN698615CL0E65. BIOS: Dell v: A11 date: 11/30/2006 
Graphics:  Device-1: Intel 82945G/GZ Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:2772 
           Display: tty server: X.Org 1.20.5 driver: modesetting compositor: kwin_x11 resolution: 1920x1200~60Hz 
           OpenGL: renderer: N/A v: N/A direct render: N/A
Comment 8 Stefan Dirsch 2019-07-18 12:02:49 UTC
(In reply to Felix Miata from comment #7)
> With Mesa-dri removed:

I would be interested into the X logfile here.
Comment 9 Felix Miata 2019-07-18 12:34:36 UTC
Created attachment 810878 [details]
Xorg.0.log from host gx62b after purging Mesa-dri

# rpmqa Mesa-dri
# inxi -GxxSM
System:    Host: gx62b Kernel: 5.1.16-1-default x86_64 bits: 64 compiler: gcc v: 9.1.1 Desktop: KDE Plasma 5.16.0 
           tk: Qt 5.13.0 wm: kwin_x11 dm: startx Distro: openSUSE Tumbleweed 20190716 
Machine:   Type: Desktop System: Dell product: OptiPlex GX620 v: N/A serial: DQ7Q891 Chassis: type: 15 serial: DQ7Q891 
           Mobo: Dell model: 0F8101 serial: ..CN698615CL0E65. BIOS: Dell v: A11 date: 11/30/2006 
Graphics:  Device-1: Intel 82945G/GZ Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:2772 
           Display: tty server: X.Org 1.20.5 driver: modesetting compositor: kwin_x11 resolution: 1920x1200~60Hz 
           OpenGL: renderer: N/A v: N/A direct render: N/A
Comment 10 Stefan Dirsch 2019-07-18 12:52:00 UTC
Ok. Seems Xserver only fails completely when swrast driver can be loaded (after installation) and doesn't fails completely if it isn't there (during installation). Please install Mesa-dri package again and try with

Section "Device"
  Identifier "Default Device"
  Driver "modesetting"
  Option "AccelMethod" "none"
EndSection

If this helps, we could use this in general during installation, since GLAMOR isn't available at this point anyway.
Comment 11 Felix Miata 2019-07-18 13:11:31 UTC
Created attachment 810891 [details]
Xorg.0.log with Mesa-dri restored and using Option "AccelMethod" "none"

# inxi -Gxx
Graphics:  Device-1: Intel 82945G/GZ Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           chip ID: 8086:2772
           Display: tty server: X.Org 1.20.5 driver: modesetting compositor: kwin_x11 resolution: 1920x1200~60Hz
           OpenGL: renderer: llvmpipe (LLVM 8.0 128 bits) v: 3.3 Mesa 19.1.2 compat-v: 3.1 direct render: Yes
Comment 12 Stefan Dirsch 2019-07-18 14:01:14 UTC
Thanks. Just opened a pull request to fix this.

https://github.com/openSUSE/installation-images/pull/326