Bug 1141720 - I2C error and no touchscreen on the Atom Windows Tablet devices Q506/ME in Tumbleweed 20190708
I2C error and no touchscreen on the Atom Windows Tablet devices Q506/ME in ...
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Windows 8.1
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-16 21:06 UTC by Kenji Shimono
Modified: 2019-10-31 12:22 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (kapper1224)


Attachments
dmesg output (188.30 KB, text/plain)
2019-07-16 21:06 UTC, Kenji Shimono
Details
Q506ME HWinfo Tumbleweed190708 (1.14 MB, text/plain)
2019-07-17 09:36 UTC, Kenji Shimono
Details
Q506ME lsmod Tumbleweed190708 (8.41 KB, text/plain)
2019-07-17 09:36 UTC, Kenji Shimono
Details
Q506ME dmesg Ubuntu19.04 (83.09 KB, text/plain)
2019-07-17 09:38 UTC, Kenji Shimono
Details
Q506ME HWinfo Ubuntu19.04 (472.87 KB, text/plain)
2019-07-17 09:39 UTC, Kenji Shimono
Details
Q506ME lsmod Ubuntu19.04 (6.98 KB, text/plain)
2019-07-17 09:40 UTC, Kenji Shimono
Details
Q506ME dmesg Archbang kernel5.1.16 (60.52 KB, text/plain)
2019-07-17 12:00 UTC, Kenji Shimono
Details
Q506ME lsmod Archbang kernel5.1.16 (7.08 KB, text/plain)
2019-07-17 12:00 UTC, Kenji Shimono
Details
No boot Tumbleweed kernel5.2.1-2 in Q506me(Another issues?) (251.72 KB, image/jpeg)
2019-07-17 18:52 UTC, Kenji Shimono
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenji Shimono 2019-07-16 21:06:01 UTC
Created attachment 810634 [details]
dmesg output

I am testing Windows Tablet in openSUSE tumbleweed 20190708.
But they are no touchscreen.
It's dmesg have I2C error.
I think 
The others linux distributions have no issues. (fixed?)

https://github.com/Syniurge/i2c-amd-mp2/issues/3
https://unix.stackexchange.com/questions/489323/changes-to-linux-driver-pinctrl-amd
https://ubuntuforums.org/archive/index.php/t-2388608.html

This is my dmesg on Q506/ME.


[    8.677183] gpio gpiochip2: (INT33FF:02): detected irqchip that is shared with multiple gpiochips: please fix the driver.
[    8.678407] i2c_hid i2c-04F3200A:00: HID over i2c has not been provided an Int IRQ
[    8.678450] i2c_hid: probe of i2c-04F3200A:00 failed with error -22
[    8.678646] gpio gpiochip3: (INT33FF:03): detected irqchip that is shared with multiple gpiochips: please fix the driver.


http://kapper1224.sakura.ne.jp/q506me.txt


Thank you.
Comment 1 Takashi Iwai 2019-07-17 05:54:43 UTC
Could you give hwinfo output?  Also if other distros are working, please get the dmesg output on the working system, as well as the lsmod output.
Comment 2 Kenji Shimono 2019-07-17 09:36:07 UTC
Created attachment 810689 [details]
Q506ME HWinfo Tumbleweed190708
Comment 3 Kenji Shimono 2019-07-17 09:36:51 UTC
Created attachment 810690 [details]
Q506ME lsmod Tumbleweed190708
Comment 4 Kenji Shimono 2019-07-17 09:38:30 UTC
Created attachment 810692 [details]
Q506ME dmesg Ubuntu19.04
Comment 5 Kenji Shimono 2019-07-17 09:39:34 UTC
Created attachment 810693 [details]
Q506ME HWinfo Ubuntu19.04
Comment 6 Kenji Shimono 2019-07-17 09:40:16 UTC
Created attachment 810695 [details]
Q506ME lsmod Ubuntu19.04
Comment 7 Kenji Shimono 2019-07-17 09:41:24 UTC
Thank you for your messages. 

I upload dmesg, HWinfo, lsmod in Tumbleweed190708 and Ubuntu19.04.
Please see it.

Thank you.
Comment 8 Takashi Iwai 2019-07-17 09:52:42 UTC
So, one obvious difference is that Ubuntu is 5.0.x while TW is 5.1.x.

I'd try at first the latest upstream 5.2.x from OBS Kernel:stable repo (maybe TW gets already that version).  If the problem persists, you can try 5.0.x TW kernel in OBS home:tiwai:kernel:5.0 repo.

If 5.0.x works and later version doesn't, it's a kernel regression and should be tracked by the upstream.

OTOH, if TW 5.0.x kernel doesn't work, it's likely a difference of kernel configuration.  For example, Ubuntu seems having the cherrytrail pinctrl driver built-in while TW has it as a module.
Comment 9 Kenji Shimono 2019-07-17 12:00:12 UTC
Created attachment 810726 [details]
Q506ME dmesg Archbang kernel5.1.16
Comment 10 Kenji Shimono 2019-07-17 12:00:49 UTC
Created attachment 810727 [details]
Q506ME lsmod Archbang kernel5.1.16
Comment 11 Kenji Shimono 2019-07-17 12:02:58 UTC
OK!

I testing Archbang and kernel5.1.16 in Q506ME now.
They can use Touchscreen and no bugs.
Attached dmesg and lsmod, but I'm sorry the Archbang has no hwinfo packages.

Let's see it.
Comment 12 Takashi Iwai 2019-07-17 12:45:17 UTC
OK, thanks.

Then let's check at first TW 5.2.1 kernel.

If this doesn't work as-is, try to reload i2c-hid module as root:
  modprobe -r i2c-hid
  modprobe i2c-hid

Does it give the very same error?
Comment 13 Kenji Shimono 2019-07-17 13:14:16 UTC
I'm sorry I don't know how to upgrade kernel from 5.1.16 to 5.2 on tumbleweed.
In 190713 TW based kernel 5.1.16, I think.
I am upgrading from 190708 to 190713...
Comment 14 Takashi Iwai 2019-07-17 13:54:50 UTC
Grab the kernel-default package from OBS Kernel:stable repository.
  http://download.opensuse.org/repositories/Kernel:/stable/standard/
and simply install it via zypper in kernel-default*.rpm.

Note that it has no proper signature, so the secure boot mode won't work.
Comment 15 Kenji Shimono 2019-07-17 18:52:46 UTC
Created attachment 810773 [details]
No boot Tumbleweed kernel5.2.1-2 in Q506me(Another issues?)
Comment 16 Kenji Shimono 2019-07-17 18:55:05 UTC
I update Tumbleweed Kernel 5.2.1-2 in Q506me, this is no boot and the another issues...
I'm sorry I can't boot it.
Comment 17 Takashi Iwai 2019-07-17 19:41:03 UTC
Weird.  It implies that the eMMC storage isn't properly set up.  Either the driver is missing, the driver doesn't work, or the device setup via udev is missing / wrong.

My wild guess is the broken initrd, but it might be something else, of course.
Comment 18 Kenji Shimono 2019-07-17 22:01:03 UTC
As you say that kernel 5.2.1 is not boot in q506me, driver problems?
I will removed this kernel 5.2.1,

But Touchscreen can operate 「〜 modprobe i2c-hid」command in kernel 5.1.16 TW.
Thank you very much.
Comment 19 Takashi Iwai 2019-07-18 06:16:12 UTC
It's not clear at this moment what is the culprit of non-bootable state.  If might be kernel, it might be something else -- if you've already upgraded anything else.

The fact that reloading i2c-hid module works means that it's either the implicit module dependency or a timing issue.

Could you try to pass rd.driver.blacklist=i2c-hid boot option (with the bootable 5.1.x TW kernel)?  It'll skip loading the module in initrd, but it should be loaded in the root fs later.
Comment 20 Jiri Slaby 2019-10-31 12:22:00 UTC
Closing due to lack of response.