Bug 1141664 - [Build 20190713] Interface disappears when editing firewall configuration in Autoinstallation conf.
[Build 20190713] Interface disappears when editing firewall configuration in ...
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AutoYaST
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
E-mail List
https://trello.com/c/Ni7JRuSh
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-16 14:05 UTC by Joaquín Rivera
Modified: 2020-07-30 11:59 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Logs from firewall edition using Autoinstalation configuration (8.95 MB, text/plain)
2019-07-17 06:22 UTC, Joaquín Rivera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joaquín Rivera 2019-07-16 14:05:01 UTC
Following steps in https://gist.github.com/dgdavid/3bb1999ea63ebf60e28340b083ab8ba8 and using profile https://gist.github.com/dgdavid/eeb157908dc72791408ec7ef0e6f6120 I noticed similar problem that we already faced in other products when changing default interface.

- Load the profile in Autoinstallation
- Click on Edit
- Add custom interface eth0
- Click on Zones
- Select any other zone different from default
- Click Set As Default
- Go back to Interfaces and click on Change Zone
- Assign the interface to default and click OK

The visual result is that the interface disappears from the UI and the expected result is that the interface stays in the UI and would have changed assignation in Zones to the corresponding to default.
Comment 1 José Iván López González 2019-07-16 15:33:50 UTC
Hi Joaquín,

First of all, thanks for reporting. Sadly, the AutoYaST editor has lost our attention during long time and currently it is crowded of bugs. In fact, we have plans to get rid of it completely. So I would start calling it a deprecated piece of software.

Anyway, we could try have a look to the bug you are reporting. Could you please attach the YaST logs?

Thanks in advance.
Comment 2 Joaquín Rivera 2019-07-17 06:22:19 UTC
Created attachment 810661 [details]
Logs from firewall edition using Autoinstalation configuration

That is good to know that it is deprecated.
Comment 3 Lukas Ocilka 2019-07-17 07:35:50 UTC
Joaquín, could you, please, describe your use case of this tool?
What you use it for and why? Is it easier for you to use AY Configuration
compared to writing / editing XML file manually? Anything else?
Comment 4 Joaquín Rivera 2019-07-17 09:28:41 UTC
Lukas, it is the first time that I use it. I'm more used to editing the XML, although I don't know how to apply a small autoyast profile like that one without the UI as I'm only try autoyast for installation not in the installed system, maybe it is documented somewhere else? It would be nice to know :)
We have a task related with steps suggested by dgdavid and it worked, but with further UI interaction is easy to find multiple bugs that we are not planning to open unless further work will be done in the future. So we are fine with open just this one in case we need to do a second round of verification if the UI tool is improved and if definitively got deprecated we can close the bug.
Comment 5 Imobach Gonzalez Sosa 2019-07-17 14:52:49 UTC
Hi Joaquín,

You are right, the UI tool is quite buggy. If you want to apply a profile to your system, you can use run the ayast_setup client:

yast ayast_setup setup filename=/path/to/your/profile

It is documented in the handbook: https://www.suse.com/documentation/sles-15/singlehtml/book_autoyast/book_autoyast.html#InstalledSystem. Of course, let me know if the documentation is confusing or not enough.

Thanks!
Comment 6 Imobach Gonzalez Sosa 2020-07-30 11:59:22 UTC
It works for me with yast2-firewall 4.3.2 and autoyast2 4.3.30 (Tumbleweed 20200728).

Let me know if you are able to reproduce the problem again.

Regards,
Imo