Bug 1141604 - KDE:Applications/akonadi-server: Bug
KDE:Applications/akonadi-server: Bug
Status: RESOLVED FIXED
: 1142680 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other SUSE Other
: P5 - None : Critical (vote)
: ---
Assigned To: Luca Beltrame
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-16 09:00 UTC by Mathias Homann
Modified: 2019-07-24 17:20 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2019-07-16 09:00:56 UTC
akonadiserver 5.11.3 is seriously broken when talking to a mysql server via tcp/ip, see https://bugs.kde.org/show_bug.cgi?id=409853

would it be possible to temporarily roll back the akonadiserver package to the previous version?
Comment 1 Wolfgang Bauer 2019-07-16 15:29:42 UTC
According to https://bugs.kde.org/show_bug.cgi?id=409753 (which looks very much like your bug), reverting this commit should fix it:
https://cgit.kde.org/akonadi.git/commit/?id=74aed9542ba1ff1e6e93a550c42869647c4eba8e

No need for downgrading the whole package.

We don't necessarily need this change anyway, as we reverted the incompatible change in Qt.
Comment 2 Wolfgang Bauer 2019-07-17 05:10:38 UTC
Please try the package from here:
https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Applications/

The standard 19.04.3 works without problems here (with the default internal database), so I suppose it only affects external database connections...
Comment 3 Mathias Homann 2019-07-17 07:38:45 UTC
yep, it does - right now my akonadi is using sqlite in a non-standard (local filesystem) location, sqlite on NFS is as bad an idea as mysql/postgresql on nfs is (which is why I had it set to do sql over tcp to my central database server).

Will try the stuff from your repo and report.
Comment 4 Mathias Homann 2019-07-17 10:28:49 UTC
(In reply to Wolfgang Bauer from comment #2)
> Please try the package from here:
> https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/
> Applications/
> 
> The standard 19.04.3 works without problems here (with the default internal
> database), so I suppose it only affects external database connections...

I tried the packages from your repository and that akonadiserver works with remote mysql just fine.
Comment 5 Wolfgang Bauer 2019-07-18 07:56:26 UTC
Ok, the new package is in KDE:Applications meanwhile, and has been forwarded to Factory.

https://build.opensuse.org/request/show/716045
https://build.opensuse.org/request/show/716146
Comment 6 Mathias Homann 2019-07-19 06:55:12 UTC
akonadiserver just got upgraded back to the packages from KDE:Applications and I can confirm fixed.
Comment 7 Wolfgang Bauer 2019-07-24 16:39:25 UTC
*** Bug 1142680 has been marked as a duplicate of this bug. ***
Comment 8 Swamp Workflow Management 2019-07-24 17:20:07 UTC
This is an autogenerated message for OBS integration:
This bug (1141604) was mentioned in
https://build.opensuse.org/request/show/718315 Factory / akonadi-server