Bug 1140421 - (CVE-2019-5052) VUL-0: CVE-2019-5052: SDL2_image: An exploitable integer overflow vulnerability exists when loading a PCX file in SDL2_image. A specially crafted file can cause an integer overflow, resulting in too little memory being allocated
(CVE-2019-5052)
VUL-0: CVE-2019-5052: SDL2_image: An exploitable integer overflow vulnerabili...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.0
Other Other
: P3 - Medium : Major (vote)
: ---
Assigned To: Ludwig Nussel
Security Team bot
https://smash.suse.de/issue/236311/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-04 14:37 UTC by Wolfgang Frisch
Modified: 2020-01-16 13:50 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2019-07-04 14:37:18 UTC
CVE-2019-5052

An exploitable integer overflow vulnerability exists when loading a PCX file in
SDL2_image 2.0.4. A specially crafted file can cause an integer overflow,
resulting in too little memory being allocated, which can lead to a buffer
overflow and potential code execution. An attacker can provide a specially
crafted image file to trigger this vulnerability.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-5052
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-5052
https://talosintelligence.com/vulnerability_reports/TALOS-2019-0821
Comment 1 Swamp Workflow Management 2019-09-05 13:13:47 UTC
openSUSE-SU-2019:2070-1: An update that fixes 12 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1135787,1135789,1135796,1135806,1136101,1140419,1140421,1141844,1143763,1143764,1143766,1143768
CVE References: CVE-2019-12217,CVE-2019-12218,CVE-2019-12220,CVE-2019-12221,CVE-2019-12222,CVE-2019-13616,CVE-2019-5051,CVE-2019-5052,CVE-2019-5057,CVE-2019-5058,CVE-2019-5059,CVE-2019-5060
Sources used:
openSUSE Leap 15.1 (src):    SDL2_image-2.0.5-lp151.2.5.1
openSUSE Leap 15.0 (src):    SDL2_image-2.0.5-lp150.9.1
Comment 2 Swamp Workflow Management 2019-09-05 13:18:57 UTC
openSUSE-SU-2019:2071-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1124827,1140421,1141844,1143763,1143764,1143766,1143768
CVE References: CVE-2019-13616,CVE-2019-5052,CVE-2019-5057,CVE-2019-5058,CVE-2019-5059,CVE-2019-5060,CVE-2019-7635
Sources used:
openSUSE Leap 15.1 (src):    SDL_image-1.2.12+hg695-lp151.3.3.1
openSUSE Leap 15.0 (src):    SDL_image-1.2.12+hg695-lp150.2.3.1
Comment 3 Swamp Workflow Management 2019-09-10 19:13:02 UTC
openSUSE-SU-2019:2108-1: An update that fixes 12 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1135787,1135789,1135796,1135806,1136101,1140419,1140421,1141844,1143763,1143764,1143766,1143768
CVE References: CVE-2019-12217,CVE-2019-12218,CVE-2019-12220,CVE-2019-12221,CVE-2019-12222,CVE-2019-13616,CVE-2019-5051,CVE-2019-5052,CVE-2019-5057,CVE-2019-5058,CVE-2019-5059,CVE-2019-5060
Sources used:
openSUSE Backports SLE-15-SP1 (src):    SDL2_image-2.0.5-bp151.4.3.1
openSUSE Backports SLE-15 (src):    SDL2_image-2.0.5-bp150.3.6.1
Comment 4 Swamp Workflow Management 2019-09-10 19:15:20 UTC
openSUSE-SU-2019:2109-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1124827,1140421,1141844,1143763,1143764,1143766,1143768
CVE References: CVE-2019-13616,CVE-2019-5052,CVE-2019-5057,CVE-2019-5058,CVE-2019-5059,CVE-2019-5060,CVE-2019-7635
Sources used:
openSUSE Backports SLE-15-SP1 (src):    SDL_image-1.2.12+hg695-bp151.4.3.1
openSUSE Backports SLE-15 (src):    SDL_image-1.2.12+hg695-bp150.3.3.1
Comment 5 Alexandros Toptsoglou 2020-01-16 13:50:11 UTC
all done. Closing