Bug 1139801 - Salt Warnings in Kubic
Salt Warnings in Kubic
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Jochen Breuer
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-30 08:34 UTC by Jason Evans
Modified: 2020-06-08 15:24 UTC (History)
3 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Evans 2019-06-30 08:34:26 UTC
I receive the following warnings when trying to run any salt commands in Kubic. The commands still run but encoding is deprecated.




master:~ # salt '*' test.ping
[WARNING ] /usr/lib/python3.7/site-packages/salt/transport/ipc.py:292: DeprecationWarning: encoding is deprecated, Use raw=False instead.
  self.unpacker = msgpack.Unpacker(encoding=encoding)

[WARNING ] /usr/lib/python3.7/site-packages/salt/payload.py:150: DeprecationWarning: encoding is deprecated, Use raw=False instead.
  ret = msgpack.loads(msg, use_list=True, ext_hook=ext_type_decoder, encoding=encoding)

worker2:
    True
worker1:
    True
Comment 1 Jochen Breuer 2019-08-22 14:30:10 UTC
Which Salt version is used in Kubic?
Comment 2 Jason Evans 2019-08-22 16:11:57 UTC
master01:~ # salt '*' test.versions_report
[WARNING ] /usr/lib/python3.7/site-packages/salt/transport/ipc.py:292: DeprecationWarning: encoding is deprecated, Use raw=False instead.
  self.unpacker = msgpack.Unpacker(encoding=encoding)

[WARNING ] /usr/lib/python3.7/site-packages/salt/payload.py:150: DeprecationWarning: encoding is deprecated, Use raw=False instead.
  ret = msgpack.loads(msg, use_list=True, ext_hook=ext_type_decoder, encoding=encoding)

master01:
    Salt Version:
               Salt: 2019.2.0
     
    Dependency Versions:
               cffi: 1.12.3
           cherrypy: Not Installed
           dateutil: Not Installed
          docker-py: Not Installed
              gitdb: Not Installed
          gitpython: Not Installed
              ioflo: Not Installed
             Jinja2: 2.10.1
            libgit2: Not Installed
            libnacl: Not Installed
           M2Crypto: Not Installed
               Mako: Not Installed
       msgpack-pure: Not Installed
     msgpack-python: 0.6.1
       mysql-python: Not Installed
          pycparser: 2.19
           pycrypto: 3.8.2
       pycryptodome: Not Installed
             pygit2: Not Installed
             Python: 3.7.3 (default, Apr 09 2019, 05:18:21) [GCC]
       python-gnupg: Not Installed
             PyYAML: 5.1.2
              PyZMQ: 18.0.2
               RAET: Not Installed
              smmap: Not Installed
            timelib: Not Installed
            Tornado: 4.5.3
                ZMQ: 4.3.2
     
    System Versions:
               dist:   
             locale: UTF-8
            machine: x86_64
            release: 5.2.8-1-default
             system: Linux
            version: Not Installed
     
worker10:
    Salt Version:
               Salt: 2019.2.0
     
    Dependency Versions:
               cffi: 1.12.3
           cherrypy: Not Installed
           dateutil: Not Installed
          docker-py: Not Installed
              gitdb: Not Installed
          gitpython: Not Installed
              ioflo: Not Installed
             Jinja2: 2.10.1
            libgit2: Not Installed
            libnacl: Not Installed
           M2Crypto: Not Installed
               Mako: Not Installed
       msgpack-pure: Not Installed
     msgpack-python: 0.6.1
       mysql-python: Not Installed
          pycparser: 2.19
           pycrypto: 3.8.2
       pycryptodome: Not Installed
             pygit2: Not Installed
             Python: 3.7.3 (default, Apr 09 2019, 05:18:21) [GCC]
       python-gnupg: Not Installed
             PyYAML: 5.1.2
              PyZMQ: 18.0.2
               RAET: Not Installed
              smmap: Not Installed
            timelib: Not Installed
            Tornado: 4.5.3
                ZMQ: 4.3.2
     
    System Versions:
               dist:   
             locale: UTF-8
            machine: x86_64
            release: 5.2.8-1-default
             system: Linux
            version: Not Installed
     
master01:~ #
Comment 3 Jochen Breuer 2019-08-23 08:50:53 UTC
This PR upstream is supposed to fix the warning, but is not merged or approved yet: https://github.com/saltstack/salt/pull/53310
Comment 4 Richard Brown 2020-06-08 15:24:00 UTC
This was fixed upstream :)