Bug 1136976 - (CVE-2019-8457) VUL-0: CVE-2019-8457: sqlite3: heap out-of-bound read in the rtreenode() function when handling invalid rtree tables
(CVE-2019-8457)
VUL-0: CVE-2019-8457: sqlite3: heap out-of-bound read in the rtreenode() func...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/234045/
CVSSv2:NVD:CVE-2019-8457:7.5:(AV:N/AC...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-05-31 12:22 UTC by Alexandros Toptsoglou
Modified: 2021-04-06 18:45 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2019-05-31 12:22:58 UTC
CVE-2019-8457

SQLite3 from 3.6.0 to and including 3.27.2 is vulnerable to heap out-of-bound
read in the rtreenode() function when handling invalid rtree tables.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-8457
http://www.cvedetails.com/cve/CVE-2019-8457/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-8457
https://www.sqlite.org/src/info/90acdbfce9c08858
https://www.sqlite.org/releaselog/3_28_0.html
Comment 1 Alexandros Toptsoglou 2019-05-31 12:24:29 UTC
Tracked all codestreams that ship sqlite3 as affected. Fix at [1] 

[1] https://www.sqlite.org/src/info/90acdbfce9c08858
Comment 2 Reinhard Max 2019-06-12 13:31:04 UTC
Not needed on Factory and SLE-15.
Backported and submitted to SLE-12-SP1, SLE-12-GA, and SLE-11-SP2.
Do we also need this for SLE-11 before SP2?
Comment 3 Alexandros Toptsoglou 2019-06-12 13:39:04 UTC
(In reply to Reinhard Max from comment #2)
> Not needed on Factory and SLE-15.
> Backported and submitted to SLE-12-SP1, SLE-12-GA, and SLE-11-SP2.
> Do we also need this for SLE-11 before SP2?

Hi Reinhard, 

thank you for your submissions. In addition to those, SLE-11:Update codestream is needed and then we are done.
Comment 6 Swamp Workflow Management 2019-06-14 19:12:25 UTC
SUSE-SU-2019:14083-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1136976
CVE References: CVE-2019-8457
Sources used:
SUSE Linux Enterprise Server 11-SP4-LTSS (src):    sqlite3-3.7.6.3-1.4.7.9.1
SUSE Linux Enterprise Point of Sale 11-SP3 (src):    sqlite3-3.7.6.3-1.4.7.9.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    sqlite3-3.7.6.3-1.4.7.9.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2019-06-17 19:19:10 UTC
SUSE-SU-2019:1522-1: An update that fixes three vulnerabilities is now available.

Category: security (important)
Bug References: 1085790,1132045,1136976
CVE References: CVE-2017-10989,CVE-2018-8740,CVE-2019-8457
Sources used:
SUSE Linux Enterprise Server 12-LTSS (src):    sqlite3-3.8.3.1-2.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2019-06-21 13:32:54 UTC
SUSE-SU-2019:1601-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1136976
CVE References: CVE-2019-8457
Sources used:
SUSE OpenStack Cloud 7 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server 12-SP4 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server 12-SP3 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    sqlite3-3.8.10.2-9.9.1
SUSE Enterprise Storage 4 (src):    sqlite3-3.8.10.2-9.9.1
SUSE CaaS Platform ALL (src):    sqlite3-3.8.10.2-9.9.1
SUSE CaaS Platform 3.0 (src):    sqlite3-3.8.10.2-9.9.1
OpenStack Cloud Magnum Orchestration 7 (src):    sqlite3-3.8.10.2-9.9.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2019-06-27 10:20:56 UTC
openSUSE-SU-2019:1645-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1136976
CVE References: CVE-2019-8457
Sources used:
openSUSE Leap 42.3 (src):    sqlite3-3.8.10.2-11.10.1
Comment 10 Swamp Workflow Management 2019-07-10 16:11:03 UTC
SUSE-SU-2019:14120-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1136976
CVE References: CVE-2019-8457
Sources used:
SUSE Linux Enterprise Debuginfo 11-SP3 (src):    sqlite3-3.6.4-4.3.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Alexandros Toptsoglou 2019-08-22 09:30:52 UTC
done