Bug 1136292 - ktorrent don't find the file "http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz"
ktorrent don't find the file "http://geolite.maxmind.com/download/geoip/data...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Applications
Leap 15.1
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks: 1156194
  Show dependency treegraph
 
Reported: 2019-05-25 19:54 UTC by a b
Modified: 2022-01-04 14:18 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
ktorrent message (54.63 KB, image/png)
2019-05-25 19:54 UTC, a b
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a b 2019-05-25 19:54:29 UTC
Created attachment 805988 [details]
ktorrent message

Please see the attachment. I get this message when I start ktorrent.
Comment 1 Wolfgang Bauer 2019-05-25 21:07:52 UTC
See https://bugs.kde.org/show_bug.cgi?id=403054.

A patch to fix it has been proposed here:
https://phabricator.kde.org/D21145

I'll have a look at adding it to our packages in the next days...
Comment 2 Wolfgang Bauer 2019-05-25 21:28:31 UTC
PS, if the error dialog annoys you too much, there seems to be a workaround:
> If "Show list of peers" under Configure / Info widget is unchecked, the popup disappears.
(from the duplicate https://bugs.kde.org/show_bug.cgi?id=407507, haven't tested it myself though)
Comment 3 Wolfgang Bauer 2019-05-25 21:28:32 UTC
PS, if the error dialog annoys you too much, there seems to be a workaround:
> If "Show list of peers" under Configure / Info widget is unchecked, the popup disappears.
(from the duplicate https://bugs.kde.org/show_bug.cgi?id=407507, haven't tested it myself though)
Comment 4 Ludwig Nussel 2020-01-03 08:00:32 UTC
Note that maxmind changed the conditions for downloading the geoip files on December 30:
https://blog.maxmind.com/2019/12/18/significant-changes-to-accessing-and-using-geolite2-databases/

So downloading those files directly won't work anymore.
Comment 5 Wolfgang Bauer 2020-01-03 09:23:14 UTC
(In reply to Ludwig Nussel from comment #4)
> Note that maxmind changed the conditions for downloading the geoip files on
> December 30:
> https://blog.maxmind.com/2019/12/18/significant-changes-to-accessing-and-
> using-geolite2-databases/
> 
> So downloading those files directly won't work anymore.

Great. So the proposed upstream patch now shows an error dialog on start as well (Unknown host geolite.maxmind.com)... :-(

At least, with this patch it is possible to disable the GeoIP functionality completely (that's not possible currently), that would also remove the error dialog of course.
Comment 6 Wolfgang Bauer 2020-01-03 17:02:55 UTC
FTR, the new way to move forward is currently being discussed in the upstream bugreport, https://bugs.kde.org/show_bug.cgi?id=403054 .

I'm thinking about patching out the download code (and the error message) in openSUSE's package for now though, until a consensus is found upstream.
Comment 7 Dashon Wells 2020-05-03 23:38:23 UTC
(In reply to Wolfgang Bauer from comment #6)
> FTR, the new way to move forward is currently being discussed in the
> upstream bugreport, https://bugs.kde.org/show_bug.cgi?id=403054 .
> 
> I'm thinking about patching out the download code (and the error message) in
> openSUSE's package for now though, until a consensus is found upstream.

Hey I was just wondering if you ever got around to patching the code in ktorrent for openSuse. I'm on Tumblweed and that pesky error still persists.
Comment 8 Wolfgang Bauer 2020-05-04 09:03:14 UTC
(In reply to Dashon Wells from comment #7)
> (In reply to Wolfgang Bauer from comment #6)
> > FTR, the new way to move forward is currently being discussed in the
> > upstream bugreport, https://bugs.kde.org/show_bug.cgi?id=403054 .
> > 
> > I'm thinking about patching out the download code (and the error message) in
> > openSUSE's package for now though, until a consensus is found upstream.
> 
> Hey I was just wondering if you ever got around to patching the code in
> ktorrent for openSuse. I'm on Tumblweed and that pesky error still persists.

Not yet, otherwise the error wouldn't be there anymore... ;-)
But as written in comment#2, you can just disable the "Show list of peers" option to get rid of the error message.
Comment 9 OBSbugzilla Bot 2021-12-22 10:10:03 UTC
This is an autogenerated message for OBS integration:
This bug (1136292) was mentioned in
https://build.opensuse.org/request/show/942085 15.2+Backports:SLE-12-SP2+Backports:SLE-12-SP3+Backports:SLE-15-SP1+Backports:SLE-15-SP2+Backports:SLE-15-SP3 / ktorrent
Comment 10 Wolfgang Bauer 2021-12-22 11:49:48 UTC
This is actually fixed meanwhile:
- Since 21.04.2, ktorrent does not try to download the (non-existing) GeoIP database anymore, which also removes the error message.
- In 21.08.0, the custom GeoIP code was removed completely and now only the system GeoIP library is supported. But we build it without, as before.

I submitted an update with the first change to Leap to get rid of the error message there as well.
Comment 11 Swamp Workflow Management 2022-01-04 14:16:53 UTC
openSUSE-RU-2022:0004-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1136292,1193480
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    libgcrypt-1.8.2-8.42.1
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    ktorrent-5.0.1-8.1
Comment 12 Swamp Workflow Management 2022-01-04 14:18:15 UTC
openSUSE-RU-2022:0004-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1136292,1193480
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    libgcrypt-1.8.2-8.42.1
openSUSE Leap 15.2 (src):    ktorrent-5.1.2-lp152.2.3.1
openSUSE Backports SLE-15-SP3 (src):    ktorrent-5.1.2-bp153.2.5.1
openSUSE Backports SLE-15-SP2 (src):    ktorrent-5.1.2-bp152.4.3.1
openSUSE Backports SLE-15-SP1 (src):    ktorrent-5.1.1-bp151.3.3.1
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    ktorrent-5.0.1-8.1