Bug 1136099 - python-nbconvert fails test on 1-core VM
python-nbconvert fails test on 1-core VM
Status: RESOLVED FIXED
: 1136098 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Todd R
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-05-23 14:53 UTC by Bernhard Wiedemann
Modified: 2020-03-30 10:26 UTC (History)
0 users

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2019-05-23 14:53:46 UTC
While working on reproducible builds for openSUSE, I found that
osc build --vm-type=kvm -j1 --noservice
for python-nbconvert fails 1 test on a 1-core VM

1 failed, 251 passed, 32 skipped, 2 deselected, 59 warnings in 241.06


 =================================== FAILURES ==========================
 ________________________ TestExecute.test_disable_stdin ______________

 self = <nbconvert.preprocessors.tests.test_execute.TestExecute testMethod=test_
disable_stdin>

     def test_disable_stdin(self): 
         """Test disabling standard input"""
         filename = os.path.join(current_dir, 'files', 'Disable Stdin.ipynb')
         res = self.build_resources()
         res['metadata']['path'] = os.path.dirname(filename)
 >       input_nb, output_nb = self.run_notebook(filename, dict(allow_errors=True), res)



If you cannot debug this yourself, please work with upstream.
Comment 1 Bernhard Wiedemann 2019-05-23 14:57:09 UTC
*** Bug 1136098 has been marked as a duplicate of this bug. ***
Comment 2 Bernhard Wiedemann 2020-03-30 10:26:02 UTC
no more a problem right now
because tests were disabled due to python-3.8 failures.