Bug 1132901 - Heavy distortions, when connecting with krdc to TigerVNC in medium quality
Heavy distortions, when connecting with krdc to TigerVNC in medium quality
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 3rd Party Driver
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
Stefan Dirsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-19 10:45 UTC by Hans-Peter Jansen
Modified: 2021-10-21 12:35 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Peter Jansen 2019-04-19 10:45:01 UTC
When connecting with krdc via TigerVNC from one TW system to another, I harvest display distortions in medium quality, and a saturated GBit ethernet connection with high quality. Only low quality behaves, but suffers from quality  perspective (as expected)

STEPS TO REPRODUCE
1. use krdc 19.03.90 and below using VNC from TW 20190403 to TW 20190403, 
2. choose medium quality, no forced resolution, no scaling
3. connect

OBSERVED RESULT
krdc displays screen okay on the first draw, then more and more distortions appear

EXPECTED RESULT
proper display

ADDITIONAL INFORMATION
when applying current HEAD of TigerVNC, the issue disappears, as done here: https://build.opensuse.org/package/show/home:frispete:RemoteDesktop/tigervnc

The server has VNC enabled within /etc/X11/xorg.conf.d/10-libvnc.conf:
Section "Module"
    Load "vnc"
EndSection

Section "Screen"
    Identifier "Screen0"
    Option "SecurityTypes" "VncAuth"
    Option "PasswordFile" "/root/.vnc/passwd"
EndSection

The Server is using 1920x1200x24 and kdm due to sddm missing XDMCP...
The krdc vnc lib is libvncclient1-0.9.12-1.1.x86_64, and tigervnc on the server is 1.9.0. 

I falsely reported this issue to https://bugs.kde.org/show_bug.cgi?id=406316, but this is not a krdc issue, but rather an unlucky parameterization. 

Given that tigervnc HEAD fixes the issue, it is most likely the culprit. Unfortunately, the diff of 1.9.0 and HEAD is rather big...
Comment 1 Hans-Peter Jansen 2019-04-19 11:23:20 UTC
Upstream bug recorded here:

https://github.com/TigerVNC/tigervnc/issues/825
Comment 2 Stefan Dirsch 2019-04-20 09:59:00 UTC
Thanks!

Ok. Let's use git master for now. New tigervnc release should be available until Leap > 15.1.

--> SR #696376
Comment 3 Swamp Workflow Management 2019-04-20 10:30:08 UTC
This is an autogenerated message for OBS integration:
This bug (1132901) was mentioned in
https://build.opensuse.org/request/show/696376 Factory / tigervnc
Comment 4 Swamp Workflow Management 2019-04-20 16:10:07 UTC
This is an autogenerated message for OBS integration:
This bug (1132901) was mentioned in
https://build.opensuse.org/request/show/696394 Factory / tigervnc