Bug 1132897 - TW20190417: tilix crashes with "tilix: symbol lookup error: tilix: undefined symbol: _D6object__T10RTInfoImplVAmA2i40i16Z4datayG2m"
TW20190417: tilix crashes with "tilix: symbol lookup error: tilix: undefined ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: Matthias Eliasson
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-19 09:35 UTC by Andrei Dziahel
Modified: 2019-04-23 18:37 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Dziahel 2019-04-19 09:35:13 UTC
Repro:

1. Start Tilix

Expected: it starts successfully

Instead: it doesn't start; running `tilix` in console prints 

> tilix: symbol lookup error: tilix: undefined symbol: _D6object__T10RTInfoImplVAmA2i40i16Z4datayG2m
Comment 1 Guillaume GARDET 2019-04-19 10:43:01 UTC
As seen on IRC, probably a rebuild of dmd/dub.
But I am not the maintainer of Tilix and I cannot perform rebuilds in Factory.
Comment 2 Andrei Dziahel 2019-04-19 11:28:28 UTC
(In reply to Guillaume GARDET from comment #1)
> As seen on IRC, probably a rebuild of dmd/dub.
> But I am not the maintainer of Tilix and I cannot perform rebuilds in
> Factory.
Comment 3 Neraste Herr10 2019-04-19 16:36:27 UTC
I have the same problem on TW with other D programs, like dub. I think this could be due to libphobos.
Comment 4 Andrei Dziahel 2019-04-20 09:16:02 UTC
(In reply to Neraste Herr10 from comment #3)
> I have the same problem on TW with other D programs, like dub. I think this
> could be due to libphobos.

Yeah, the DMD has been updated 6 days ago. The question is why it didn't trigger tilix rebuild.
Comment 5 Matthias Eliasson 2019-04-23 18:37:34 UTC
The issue was caused by missing rebuilds of dependent packages of phobos lib after upgrade of dmd. The rebuilds should have been done after request in IRC. Tilix should be working again since 20190420 snapshot. 

I am not sure why the rebuild was not triggered automatically by OBS. However during SR with upgrade of DMD (d-compiler) in the future, I will remind the Factory maintainers that rebuilds of dependent packages is required for such upgrades.