Bug 1132895 - korganizer crashes on startup
korganizer crashes on startup
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-19 08:52 UTC by Kris Scott
Modified: 2019-04-23 13:23 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
backtrace (7.50 KB, text/plain)
2019-04-19 08:52 UTC, Kris Scott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kris Scott 2019-04-19 08:52:25 UTC
Created attachment 803247 [details]
backtrace

Fresh install of tumbleweed, so I don't think there is any old files or settings messing with it. No useful messages to stdout either.
Comment 1 Kris Scott 2019-04-19 08:56:07 UTC
Since it seems possibly to be an issue with qdatetime, here's my locale and tmezone:

LANG=en_CA.UTF-8
LC_CTYPE="en_CA.UTF-8"
LC_NUMERIC="en_CA.UTF-8"
LC_TIME=en_GB.UTF-8
LC_COLLATE=ja_JP.UTF-8
LC_MONETARY="en_CA.UTF-8"
LC_MESSAGES="en_CA.UTF-8"
LC_PAPER=ja_JP.UTF-8
LC_NAME="en_CA.UTF-8"
LC_ADDRESS="en_CA.UTF-8"
LC_TELEPHONE="en_CA.UTF-8"
LC_MEASUREMENT=en_CA.UTF-8
LC_IDENTIFICATION="en_CA.UTF-8"
LC_ALL=

/etc/localtime -> /usr/share/zoneinfo/Asia/Tokyo
Comment 2 Wolfgang Bauer 2019-04-19 09:00:46 UTC
See https://bugs.kde.org/show_bug.cgi?id=404275
Comment 3 Wolfgang Bauer 2019-04-23 13:23:06 UTC
FYI, I was able to reproduce the crash by changing /etc/localtime to point to /usr/share/zoneinfo/Asia/Tokyo on my system.
So I wanted to try the fix that was mentioned in the KDE bugreport that will be in Qt 5.12.4.
It seems that it's fixed in Qt 5.12.3 already though, after I updated to that korganizer starts fine again.

Qt 5.12.3 has already been submitted to Factory/Tumbleweed and should arrive in the repos soon.

In other words, there's nothing for us to do here anymore... ;-)

If you need a fix urgently, you can install libQt5Core5 5.12.2 with additional patches from here:
https://build.opensuse.org/package/binaries/home:wolfi323:branches:KDE:Qt:5.12/libqt5-qtbase/openSUSE_Tumbleweed