Bug 1132880 - E: [pulseaudio] ltdl-bind-now.c: Failed to open module /usr/lib64/pulse-12.2/modules/module-alsa-card.so: /usr/lib64/pulse-12.2/modules/libalsa-util.so: undefined symbol: pa_alsa_ucm_device_update_available
E: [pulseaudio] ltdl-bind-now.c: Failed to open module /usr/lib64/pulse-12.2/...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Sound
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-18 20:24 UTC by Zbigniew Luszpinski
Modified: 2019-04-21 09:52 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zbigniew Luszpinski 2019-04-18 20:24:18 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0
Build Identifier: 

openSUSE Tumbleweed 20190417
Today (18.04.2019) zypper dup updated pulseaudio package to broken version. Pulseaudio does not start anymore with error:
E: [pulseaudio] ltdl-bind-now.c: Failed to open module /usr/lib64/pulse-12.2/modules/module-alsa-card.so: /usr/lib64/pulse-12.2/modules/libalsa-util.so: undefined symbol: pa_alsa_ucm_device_update_available

Name        : pulseaudio
Version     : 12.2
Release     : 3.1
Architecture: x86_64
Install Date: Thu Apr 18 18:10:23 2019
Group       : System/Sound Daemons
Size        : 3927791
Signature   : RSA/SHA256, Wed Apr 17 10:57:34 2019, Key ID b88b2fd43dbdc284
Source RPM  : pulseaudio-12.2-3.1.src.rpm
Build Date  : Wed Apr 17 10:56:44 2019
Build Host  : cloud113
Packager    : https://bugs.opensuse.org
Vendor      : openSUSE

Reproducible: Always

Steps to Reproduce:
zypper dup
reboot

Actual Results:  
E: [pulseaudio] ltdl-bind-now.c: Failed to open module /usr/lib64/pulse-12.2/modules/module-alsa-card.so: /usr/lib64/pulse-12.2/modules/libalsa-util.so: undefined symbol: pa_alsa_ucm_device_update_available

Expected Results:  
pulseaudio should start correctly without broken modules.

Please fix pulseaudio-12.2-3.1.x86_64.rpm or rollback pulseaudio-12.2-2.2.x86_64.rpm
Comment 1 Zbigniew Luszpinski 2019-04-18 22:11:08 UTC
Confirmed: upgrading to pulseaudio-12.2-3.1.x86_64.rpm makes all soundcards disappear and after executing pulseaudio command error is visible:
E: [pulseaudio] ltdl-bind-now.c: Failed to open module /usr/lib64/pulse-12.2/modules/module-alsa-card.so: /usr/lib64/pulse-12.2/modules/libalsa-util.so: undefined symbol: pa_alsa_ucm_device_update_available

Workaround:
wget https://rpmfind.net/linux/opensuse/tumbleweed/repo/oss/x86_64/pulseaudio-12.2-2.2.x86_64.rpm
zypper in -f pulseaudio-12.2-2.2.x86_64.rpm
reboot
Comment 2 Konstantin Voinov 2019-04-20 02:08:07 UTC
Confirm.

I don't see breaking differences with previous revision, strange...
Comment 3 Takashi Iwai 2019-04-20 16:18:16 UTC
I rebuilt pulseaudio package on the latest TW from the previous release, and the resultant package is still broken in this regard.  So it is likely something else (like the basic toolchain) that caused this regression.
Please check the packages in OBS home:tiwai:branches:multimedia:libs/pulseaudio in your side, too.

But, note that this is only about the card module and the other sink/source modules seem working fine.  That's reason it works on other users (and it passes openQA that includes the basic audio testing).

That said, the cause of the complete loss of the sound is something else.  A possible cause is the system user socket activation, for example.

Unfortunately there have been so many changes between them...  But in anyway, please check the package above, and see whether it restores the sound functionality.  This is a first step.
Comment 4 Konstantin Voinov 2019-04-20 23:26:55 UTC
I have to say that pulseaudio works (sound, cards in mixer), though undefined symbols message is present.
The package from main repo.
Comment 5 Takashi Iwai 2019-04-21 09:48:50 UTC
OK, found out the culprit.  It was due to the recent removal of -I$include/alsa path from alsa pkgconfig (bug 1130333).

The UCM code in PA still included the header directly without alsa/ prefix.
Comment 6 Takashi Iwai 2019-04-21 09:52:33 UTC
The fix merged into OBS multimedia:libs and forwarded to FACTORY now.