Bug 1132848 - [201904147] installation-images:MicroOS does not have correct libzypp config
[201904147] installation-images:MicroOS does not have correct libzypp config
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: MicroOS
Current
Other Other
: P1 - Urgent : Normal (vote)
: ---
Assigned To: YaST Team
E-mail List
https://trello.com/c/2a5s6Smy/3052-mi...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-18 10:29 UTC by Dominique Leuenberger
Modified: 2019-04-24 12:00 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-04-18 10:29:23 UTC
Identified by openQA:

https://openqa.opensuse.org/tests/911048#step/libzypp_config/4

# Test died: command 'egrep -x "^solver.onlyRequires ?= ?true" /etc/zypp/zypp.conf' failed at /var/lib/openqa/cache/openqa1-opensuse/tests/microos/tests/caasp/libzypp_config.pm line 20.
Comment 1 Fabian Vogt 2019-04-18 11:44:55 UTC
Edited title to make it more obvious what the issue is
Comment 2 Dominique Leuenberger 2019-04-18 11:51:04 UTC
if InstallationImages then snwint :)
Comment 3 Lukas Ocilka 2019-04-18 12:16:46 UTC
If snwint then "you have a problem" || you have to wait

# Installation images != [snwint]
# Well, should not ...
Comment 5 Lukas Ocilka 2019-04-18 12:26:05 UTC
if (theme eq 'CAASP') || (theme eq 'Kubic') || (theme eq 'MicroOS') ?

This might work...
Comment 6 Stefan Schubert 2019-04-23 11:42:07 UTC
(In reply to Lukas Ocilka from comment #5)
> if (theme eq 'CAASP') || (theme eq 'Kubic') || (theme eq 'MicroOS') ?
> 
> This might work...

Good catch ! Moved to Trello.
Comment 7 Steffen Winterfeldt 2019-04-23 14:00:58 UTC
Basically, yes.

Although it might be time to introduce a config setting like 'patch_zypp_config=0|1' in etc/config per theme and use it instead.
Comment 8 Lukas Ocilka 2019-04-24 08:50:18 UTC
Looks like having configurations for various settings is more transparent
than hard-coded names and other stuff. /me votes for that solution :)
Comment 9 Richard Brown 2019-04-24 10:04:27 UTC
(In reply to Lukas Ocilka from comment #8)
> Looks like having configurations for various settings is more transparent
> than hard-coded names and other stuff. /me votes for that solution :)

+1 :)

But thanks to all here for diagnosing this so quickly

Can I possibly have a rough ETA for a fix?
I consider this bug a blocker for the formal 'public' launch of MicroOS, but if all goes well I plan to solve the other issues we have in parallel to this so MicroOS can launch as a stand alone offering in a week or two.

Cheers
Comment 10 Lukas Ocilka 2019-04-24 10:19:10 UTC
Then it's not a P2, but P1
It did not make it to the current sprint, I'll push it there
Comment 11 Steffen Winterfeldt 2019-04-24 12:00:41 UTC
fixed

https://github.com/openSUSE/installation-images/pull/307