Bug 1132829 - UPNP does not work in VLC
UPNP does not work in VLC
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
x86-64 Other
: P2 - High : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-18 06:44 UTC by Sebastien CHAVAUX
Modified: 2020-04-22 12:00 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Fix bug upnp libupnp13 (5.27 KB, patch)
2019-10-22 18:55 UTC, Sebastien CHAVAUX
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien CHAVAUX 2019-04-18 06:44:25 UTC
My title may be inappropriate, I apologize.
I'm on openSUSE Tumbleweed (updated at this date), I have for several months (27/11/18 - https://bugzilla.opensuse.org/show_bug.cgi?id=1117448) an impossibility to browse from VLC the UPNP network.

The output in a console gives this:

~$ vlc
VLC media player 3.0.6 Vetinari (revision 3.0.6-0-g5803e85f73)
[000055c090630ce0] main libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[000055c09062b350] main playlist: playlist is empty
[00007f401c656f60] upnp services discovery: Initializing libupnp on 'default' interface
[00007f401c656f60] upnp services discovery error: Initialization failed: UPNP_E_SOCKET_BIND
[00007f401c656f60] main services discovery error: no suitable services discovery module
[00007f401c656f60] upnp services discovery: Initializing libupnp on 'default' interface
[00007f401c656f60] upnp services discovery error: Initialization failed: UPNP_E_SOCKET_BIND
[00007f401c656f60] main services discovery error: no suitable services discovery module


I am with the VLC OSS repositories, but I can also change and put the one of packman and it does not change.

I tested on an openSUSE without third-party repositories (without packman) and the problem exists.

Thank you for your time.
Comment 1 Mauro Gaspari 2019-08-06 05:59:13 UTC
Hello,

I have tried it on my up-to-date tumbleweed and I can browse DLNA/uPNP network with VLC.
What I did is:
1. Open VLC
2. Go to View - Playlist
3. Browse to local network
4. Select Universal Plug'n'Play
5. My server appears and I can browse it, play music, etc.

Could you please test and see if you still have the issue?
Comment 2 Sebastien CHAVAUX 2019-10-22 18:55:55 UTC
Created attachment 822210 [details]
Fix bug upnp libupnp13

available on my home:

https://build.opensuse.org/package/show/home%3Aseb95passionlinux/libupnp
Comment 3 Sebastien CHAVAUX 2019-10-22 18:57:33 UTC
The trouble comes from upnp (libupnp 13), see the bug for debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=932460
https://github.com/mrjimenez/pupnp/issues/91

due to the --enable-reusaddr option ...

>When libupnp is configured with --enable-reuseaddr, it does not retry with a different port if the default one (49152) is busy.
>
>This makes it difficult to run multiple apps (e.g. renderer + control point or multiple control points) on the same host. The second libupnp-based application fails if it tries to use the default port. The only workaround would be to manually configure different ports, but this is a major regression compared to the current situation where the next available port is just used.
>
>There is no contradiction between setting reuseaddr, so that a restart of a single application will use the same port (which can help with firewalls etc.), and also trying the next available value if the first one is actually busy.
>
>Debian and Ubuntu already package the library with --enable-reuseaddr so this is a major issue.

You have to patch upnp to fill this known bug. In the archive for debian de deb-multimedia, christian made a patch:
https://deb-multimedia.org/dists/unstable/main/binary-amd64/package/libupnp13

I took it back to put it in the openSUSE package. I am not sure of myself, so I allow myself to transmit here the original patch.

Thanks for correcting the worries on libupnp13.
Comment 4 Dominique Leuenberger 2020-04-22 07:38:15 UTC
(In reply to Sebastien Chavaux from comment #3)
> The trouble comes from upnp (libupnp 13), see the bug for debian:
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=932460
> https://github.com/mrjimenez/pupnp/issues/91

This was actually addressed by libupnp 1.10.1 in the meantime; so this problem should be solved for you, right?
Comment 5 Mauro Gaspari 2020-04-22 11:53:18 UTC
(In reply to Dominique Leuenberger from comment #4)
> (In reply to Sebastien Chavaux from comment #3)
> > The trouble comes from upnp (libupnp 13), see the bug for debian:
> > https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=932460
> > https://github.com/mrjimenez/pupnp/issues/91
> 
> This was actually addressed by libupnp 1.10.1 in the meantime; so this
> problem should be solved for you, right?

Hello,
Confirmed it is now working ok, thanks!
Comment 6 Dominique Leuenberger 2020-04-22 12:00:32 UTC
(In reply to Mauro Gaspari from comment #5)
> Hello,
> Confirmed it is now working ok, thanks!

Perfect; thanks for confirming