Bug 1131754 - sssd fails to start due to a ldb module version mismatch (after installing updates on 2019-04-05)
sssd fails to start due to a ldb module version mismatch (after installing up...
Status: RESOLVED DUPLICATE of bug 1131686
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Samba
Leap 15.0
x86-64 SUSE Other
: P5 - None : Critical (vote)
: ---
Assigned To: The 'Opening Windows to a Wider World' guys
The 'Opening Windows to a Wider World' guys
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-04-06 09:53 UTC by Manfred Hupfer
Modified: 2019-04-06 14:04 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Hupfer 2019-04-06 09:53:11 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build Identifier: 

# rcsssd status
* sssd.service - System Security Services Daemon
   Loaded: loaded (/usr/lib/systemd/system/sssd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2019-04-06 11:23:34 CEST; 17min ago
  Process: 4985 ExecStart=/usr/sbin/sssd -i ${DEBUG_LOGGER} (code=exited, status=4)
 Main PID: 4985 (code=exited, status=4)

Apr 06 11:23:34 pcito20.leistritz.de systemd[1]: Starting System Security Services Daemon...
Apr 06 11:23:34 pcito20.leistritz.de sssd[4985]: ldb: module version mismatch in ../source4/dsdb/samdb/ldb_modules/acl.c : ldb_version=1.2.4 module_version=1.2.3
Apr 06 11:23:34 pcito20.leistritz.de sssd[4985]: ldb: failed to initialise module /usr/lib64/ldb/samba/acl.so : Unavailable
Apr 06 11:23:34 pcito20.leistritz.de sssd[4985]: ldb: failed to initialise module /usr/lib64/ldb/samba : Unavailable
Apr 06 11:23:34 pcito20.leistritz.de sssd[4985]: SSSD couldn't load the configuration database [5]: Input/output error.
Apr 06 11:23:34 pcito20.leistritz.de systemd[1]: sssd.service: Main process exited, code=exited, status=4/NOPERMISSION
Apr 06 11:23:34 pcito20.leistritz.de systemd[1]: Failed to start System Security Services Daemon.
Apr 06 11:23:34 pcito20.leistritz.de systemd[1]: sssd.service: Unit entered failed state.
Apr 06 11:23:34 pcito20.leistritz.de systemd[1]: sssd.service: Failed with result 'exit-code'.


Reproducible: Always

Steps to Reproduce:
1. zypper up
2. reboot
3. verify sssd status
Actual Results:  
sssd fails to start, domain users cannot log on!

Expected Results:  
sssd starts successfully as it did before the update on Friday, April 5. 

Previous "zypper up" run was roughly one week before.
Comment 1 Manfred Hupfer 2019-04-06 11:57:44 UTC
Package versions affected:
samba-dsdb-modules-4.7.10+git.124.8d97fe90926-lp150.3.9.1.x86_64
sssd-1.16.1-lp150.2.9.1
Comment 2 Oliver Eichler 2019-04-06 12:47:29 UTC
I can confirm. Got bitten by the same version mismatch. No user login any more.
Comment 3 Marcus Meissner 2019-04-06 14:04:39 UTC
dup of 1131686

*** This bug has been marked as a duplicate of bug 1131686 ***