Bug 1130896 - Letter "c" stops functioning while using freerdp
Letter "c" stops functioning while using freerdp
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
Leap 15.0
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Johannes Weberhofer
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-28 21:01 UTC by Steven Moring
Modified: 2020-06-08 12:54 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Moring 2019-03-28 21:01:11 UTC
Using "freerdp-2.0.0~rc4-lp150.2.3.1.x86_64"

While running:

# xfreerdp /v:<ip address> /u:<userid> /p:<password> /cert-ignore -sec-nla /multimon /sound /toggle-fullscreen +clipboard +fonts +compression +heartbeat

Sporadically the letter "c" on the keyboard stops functioning, disconnecting and restarting the remote connection clears the symptom.  This occurs on more than one machine and with more than one remotely controlled Windows 10 machine.

Any advice on how to gather diagnostics?
Comment 1 Steven Moring 2019-04-01 17:33:36 UTC
Additional information from today.

À à À, à (a-grave) is a letter of the Catalan, Dutch, Emilian-Romagnol, French, Galician, Italian, Occitan, Portuguese, Sardinian, Hungarian, Scottish Gaelic, Vietnamese, and Welsh languages consisting of the letter A of the ISO basic Latin alphabet and a grave accent. À is also used in Pinyin transliteration.

The letter A is somehow being translated into a-grave " à " when remotely controlling a Windows 10 machine and typing the letter "A".

Keyboard and language are both English for the Linux and Windows machines.

Any idea how this could be happening and where I'd go about diagnosing it?
Comment 2 Bruno Friedmann 2019-04-01 19:50:04 UTC
xfreerdp is working absolutely well with TW and controling win7, win10, windows 2016 and windows 2019

so affecting to last commiter.
Comment 3 Johannes Weberhofer 2019-04-02 07:37:20 UTC
Please report your issues upstream. I have found two issues which could be related:

* https://github.com/FreeRDP/FreeRDP/issues/4966
* https://github.com/FreeRDP/FreeRDP/issues/4137
Comment 4 Steven Moring 2019-04-02 10:20:46 UTC
(In reply to Bruno Friedmann from comment #2)
> xfreerdp is working absolutely well with TW and controling win7, win10,
> windows 2016 and windows 2019
> 
> so affecting to last commiter.

Works on os423.  Does not work properly on os150.
Comment 5 Steven Moring 2019-04-02 10:22:05 UTC
(In reply to Johannes Weberhofer from comment #3)
> Please report your issues upstream. I have found two issues which could be
> related:
> 
> * https://github.com/FreeRDP/FreeRDP/issues/4966
> * https://github.com/FreeRDP/FreeRDP/issues/4137

Thank you Johannes.  These do sound similar indeed.

I'm not sure how I would go about reporting this upstream.  Have some hints for me?
Comment 6 Johannes Weberhofer 2019-04-02 10:32:20 UTC
I think it would be good just to add the information to the related tickets. Sometimes it's really hard to reproduce things and it would definitely help developers when they know that you have the problem and you can reproduce it.

Btw: Do you have the latest updates for 42.3 installed? Because they should bring the code up to the same level as in 15.0.
Comment 7 Steven Moring 2019-04-02 10:49:12 UTC
(In reply to Johannes Weberhofer from comment #6)
> I think it would be good just to add the information to the related tickets.
> Sometimes it's really hard to reproduce things and it would definitely help
> developers when they know that you have the problem and you can reproduce it.
> 
> Btw: Do you have the latest updates for 42.3 installed? Because they should
> bring the code up to the same level as in 15.0.

os423 (all flavors) don't have this symptom.
os150 (base) has other issues that make it unusable (mouse and screen artifacts)
os150 (current) has the symptom (freerdp-2.0.0~rc4-lp150.2.3.1.x86_64)

The most current version for os423 is freerdp-2.0.0~git.1463131968.4e66df7-13.1.x86_64, I can't tell you that the commits are the same between os423 and os150, I have to rely upon you for that information.

I will update both of the two links you sent with pertinent information.
Comment 9 Johannes Weberhofer 2020-06-08 12:54:39 UTC
As freerdp has been updated several times in the last months, I'll close this issue.
Please open a new big if the issue is still relevant for supported openSUSE versions.