Bug 1130293 - YaST2 Oxygen (not Breeze) icon theme is installed, but I see Hicolor icons in YaST
YaST2 Oxygen (not Breeze) icon theme is installed, but I see Hicolor icons in...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/A7tXt5KH
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-24 18:56 UTC by Mindaugas Baranauskas
Modified: 2020-01-02 15:45 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
yast2-control-center-qt 4.1.6 - YaST2 with Oxygen icons (openSUSE Tumbleweed 20190226) (769.27 KB, image/png)
2019-03-24 18:56 UTC, Mindaugas Baranauskas
Details
yast2-control-center-qt 4.1.7 - YaST2 with Breeze icons (762.57 KB, image/png)
2019-03-24 18:58 UTC, Mindaugas Baranauskas
Details
yast2-control-center-qt 4.1.7 - YaST2 with Breeze icons -- login as root in KDE Plasma 5 with Oxygen as default icon theme (638.88 KB, image/png)
2019-03-24 19:10 UTC, Mindaugas Baranauskas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mindaugas Baranauskas 2019-03-24 18:56:46 UTC
Created attachment 801024 [details]
yast2-control-center-qt 4.1.6 - YaST2 with Oxygen icons (openSUSE Tumbleweed 20190226)

I had openSUSE Tumbleweed 20190226 version - LiveCD.
This snapshot had updated and again usable Oxygen icon theme for YaST, because of https://github.com/yast/yast-theme/pull/107 in 2019-02-15
(see also https://bugzilla.opensuse.org/show_bug.cgi?id=1125450)

After update to newer openSUSE Tumbleweed version, icons in YaST2 control center changed from Oxygen to Breeze, though I did not install YaST breeze icon theme!

I found that the cause was update to yast2-control-center-qt from 4.1.6 version to 4.1.7 version. This is caused by faulty "Introduce very effective fallback for icons" (boo#1127245)
Comment 1 Mindaugas Baranauskas 2019-03-24 18:58:30 UTC
Created attachment 801025 [details]
yast2-control-center-qt 4.1.7 - YaST2 with Breeze icons
Comment 2 Sasi Olin 2019-03-24 19:02:36 UTC
Did you change your icon theme for root too? YaST runs as root, so switching the root icon theme is required to change icon theme.
Comment 3 Mindaugas Baranauskas 2019-03-24 19:08:37 UTC
Even if I login as root into KDE Plasma 5 desktop, where Oxygen icon theme is used as default icon theme for Plasma desktop, then YaST2 still use Breeze icons.
Comment 4 Mindaugas Baranauskas 2019-03-24 19:10:44 UTC
Created attachment 801026 [details]
yast2-control-center-qt 4.1.7 - YaST2 with Breeze icons -- login as root in KDE Plasma 5 with Oxygen as default icon theme
Comment 5 Sasi Olin 2019-03-24 19:11:48 UTC
Those are hicolor icons :/
Comment 6 Mindaugas Baranauskas 2019-03-24 19:14:29 UTC
Seems buggy implementation introduced with 
https://github.com/yast/yast-control-center/commit/c93adf77412d67debe90884ed8dcec3c2f546dd6 

Yes, there I see lines about hicolor as fallback:

    // qt5ct doesn't set a default theme
    if ( QIcon::themeName().isEmpty() )
    {
        QIcon::setThemeName( "hicolor" );
    }

(https://github.com/yast/yast-control-center/commit/c93adf77412d67debe90884ed8dcec3c2f546dd6#diff-1600f20d47e25cf1adc481bd42972e9eR279)
Comment 7 Sasi Olin 2019-03-24 19:16:51 UTC
Yeah, that was necessary for situations where no theme is applied, it shouldn't really matter if the theme is set from qt settings (the alternative to that are no icons at all in some desktop environments)
Comment 8 Mindaugas Baranauskas 2019-03-24 19:20:20 UTC
Thus we need to check not only  qt settings, but also desktop icon theme settings.
Comment 9 Mindaugas Baranauskas 2019-03-24 19:24:33 UTC
If I install yast2-theme-breeze and set desktop icon theme to Breeze – icons in YaST2 control center does not change (they remains to be Hicolor)
Comment 10 Josef Reidinger 2020-01-02 15:45:06 UTC
should be fixed with https://github.com/yast/yast-control-center/pull/44/files

please reopen if it still happpens.

Thanks