Bug 1129257 - [Build 20190313] Installer offers product twice
[Build 20190313] Installer offers product twice
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P1 - Urgent : Major (vote)
: ---
Assigned To: Ladislav Slezák
Jiri Srain
https://openqa.opensuse.org/tests/879...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-14 14:10 UTC by Dominique Leuenberger
Modified: 2022-09-12 10:30 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-03-14 14:10:35 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-textmode@64bit fails in
[welcome](https://openqa.opensuse.org/tests/879735/modules/welcome/steps/7)

## Test suite description
Maintainer: okurz

Installation in textmode and selecting the textmode "desktop" during installation.


## Reproducible

Fails since (at least) Build [20190312](https://openqa.opensuse.org/tests/878306)


## Expected result

Last good: [20190311](https://openqa.opensuse.org/tests/877684) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?flavor=NET&test=textmode&version=Tumbleweed&distri=opensuse&arch=x86_64&machine=64bit)


openSUSE Tumbleweed is listed twice as available product - changing the UI completely and asking the user for a weird selection between Tumbleeweed and Tumbleweed)

Since this is not a staging test, but a snapshot test, future snapshots are blocked until resolved
Comment 1 Dominique Leuenberger 2019-03-14 14:11:25 UTC
https://github.com/yast/yast-yast2/commit/48755503dfdaff417bd9e6cd4f88261afb5e6eb6 is potentially involved; that change entered Factory in snapshot 0313
Comment 2 Ladislav Slezák 2019-03-14 14:48:47 UTC
Yes, that's related...
Comment 4 Ladislav Slezák 2019-03-14 16:55:49 UTC
Fixed in yast2-4.1.65 (https://github.com/yast/yast-yast2/pull/910, https://build.opensuse.org/request/show/685077)