Bug 1128780 - mysql-workbench 8.x crashes with mySQL 8.0 ...
mysql-workbench 8.x crashes with mySQL 8.0 ...
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Linux
: P5 - None : Normal (vote)
: ---
Assigned To: Mykola Krachkovsky
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-11 20:27 UTC by André Verwijs
Modified: 2021-01-20 10:00 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
w01dnick: needinfo? (dutch.glory)


Attachments
wb.log (2.13 KB, text/x-log)
2019-03-11 20:27 UTC, André Verwijs
Details
Log file "normal" user (not root) (2.15 KB, text/plain)
2019-03-12 03:19 UTC, andre verwijs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Verwijs 2019-03-11 20:27:15 UTC
Created attachment 799648 [details]
wb.log

Using OpenSUSE Tumbleweed:

Operating System: OpenSUSE Tumbleweed 2019.03.07
KDE Plasma Version: 5.15.2
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.0
Kernel Version: 4.20.13-1-default
OS Type: 64-bit
Processors: 2 × Intel® Core™2 CPU 6700 @ 2.66GHz
Memory: 5,8 GiB

downloaded/installed mysql-workbench from:
http://download.opensuse.org/repositories/server:/database/openSUSE_Tumbleweed/

when i try to connect to mysql, mysql-workbench crashes (root an non-root) 

WB.log:
23:50:28 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /usr/share/mysql-workbench
	plugin path: /usr/lib64/mysql-workbench/plugins
	struct path: /usr/share/mysql-workbench/grt
	module path: /usr/lib64/mysql-workbench/modules
	library path: /usr/share/mysql-workbench/libraries
	user data dir: /root/.mysql/workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
23:50:28 [INF][      WBContext]: WbContext::init
23:50:28 [WRN][            grt]: Could not load wb.model.grt.so: Could not open module /usr/lib64/mysql-workbench/modules/wb.model.grt.so (/usr/lib64/mysql-workbench/modules/wb.model.grt.so: undefined symbol: _ZN9Scintilla8WordListD1Ev)	
23:50:28 [INF][            WBA]: Looking for extension modules for WBA...
23:50:28 [INF][            WBA]: 0 extension modules found
23:50:28 [WRN][            grt]: Could not load db.mysql.diff.reporting.wbp.so: Could not open module /usr/lib64/mysql-workbench/plugins/db.mysql.diff.reporting.wbp.so (/usr/lib64/mysql-workbench/plugins/db.mysql.diff.reporting.wbp.so: undefined symbol: _Z17build_catalog_mapN3grt3RefI16db_mysql_CatalogEERSt3mapINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEENS0_I14GrtNamedObjectEESt4lessIS9_ESaISt4pairIKS9_SB_EEE)	
23:50:28 [WRN][            grt]: /usr/share/mysql-workbench/modules/data/mysql_rdbms_info.xml:1446: link 'om.mysql.rdbms.mysql.driver.native_sshtun' <object > key=owner could not be resolved
23:50:28 [WRN][            grt]: /root/.mysql/workbench/connections.xml:23: link 'aa7b93dc-4386-11e9-a89e-0019d1852a92' <object GrtObject> key=owner could not be resolved
23:50:28 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Linux/Unix version 8.0.15 CE build 14271522 (64 bit)
	Configuration Directory: /root/.mysql/workbench
	Data Directory: /usr/share/mysql-workbench
	Cairo Version: 1.16.0
	OS:  x86_64
	CPU: 2x Intel(R) Core(TM)2 CPU          6700  @ 2.66GHz (2072.567MHz) - 5,75GiB RAM
No video adapter info available
	Fips mode enabled: no

23:50:28 [WRN][       WBModule]: OS not found on supported OS list. OS string: ' x86_64'
Comment 1 andre verwijs 2019-03-12 03:19:59 UTC
Created attachment 799669 [details]
Log file "normal" user (not root)

Log file when starting mysql-workbench "normal" user (not root)
Comment 2 Mykola Krachkovsky 2019-03-15 08:44:51 UTC
Hmm. First about logs.

Problem in logs with libscintilla (loading of wb.model.grt.so) - it turned out I also have it, but in every scenario I'm using workbench it is working fine, so I've missed it, thanks.

I can't reproduce second problem from logs (loading of db.mysql.diff.reporting.wbp.so). Could you show output of these:
`ldd /usr/lib64/mysql-workbench/plugins/db.mysql.diff.reporting.wbp.so`
`ldd /usr/lib64/mysql-workbench/plugins/db.mysql.wbp.so`
?

And finally about crash. Both problems are definitely should be fixed, but they aren't looking as crash direct reasons. Could you run mysql-workbench from terminal:
`mysql-workbench 2>mywb-err.log 1>mywb-out.log`
and attach mywb-err.log and mywb-out.log?
Comment 3 Mykola Krachkovsky 2021-01-20 10:00:27 UTC
Hi, I'm sorry, if this is still relevant, but there is no any feedback for almost a two years, so I'll closing this. If someone will encounter this problem feel free to reopen (or create a new) bugreport.