Bug 1127435 - nothing provides python2-sip(api) = 12.5 needed by python2-qt4-4.12.3-1.3.x86_64
nothing provides python2-sip(api) = 12.5 needed by python2-qt4-4.12.3-1.3.x86_64
Status: RESOLVED DUPLICATE of bug 1125542
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dirk Mueller
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-28 22:42 UTC by Rich Coe
Modified: 2019-03-01 06:13 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rich Coe 2019-02-28 22:42:07 UTC
I'm trying to install a package which depends on python2-qt4.
python2-qt4 depends on python2-sip.

Name        : python2-sip
Version     : 4.19.14
Release     : 1.1

rpm -q --provides python2-sip
python-sip = 4.19.14-1.1
python2-sip = 4.19.14-1.1
python2-sip(api) = 12.6
python2-sip(x86-64) = 4.19.14-1.1

Looks like python2-sip was upgraded and python2-qt4 was not.

"older system"
rpm -q --provides python2-sip
python-sip = 4.19.13-1.1
python2-sip = 4.19.13-1.1
python2-sip(api) = 12.5
python2-sip(x86-64) = 4.19.13-1.1

"older system"
rpm -q -R python2-qt4
[...]
python(abi) = 2.7
python2-dbus-python >= 1.2.8
python2-qt4-utils
python2-sip(api) = 12.5

"older system"
rpm -q --info python2-qt4
Name        : python2-qt4
Version     : 4.12.1
Release     : 2.5
Comment 1 Wolfgang Bauer 2019-03-01 06:13:53 UTC
Duplicate.

*** This bug has been marked as a duplicate of bug 1125542 ***