Bug 1127411 - yast2-vm not included when installing Server role
yast2-vm not included when installing Server role
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-28 17:56 UTC by James Fehlig
Modified: 2019-06-24 07:40 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
yast2 logs (1.19 MB, application/x-xz)
2019-02-28 17:56 UTC, James Fehlig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Fehlig 2019-02-28 17:56:54 UTC
Created attachment 798469 [details]
yast2 logs

I would expect the 'yast2 virtualization' module to be present when installing TW with the Server role selected. I installed TW 20190226 with Server role and found yast2-vm was not installed. After installing it manually I was able to access the 'yast2 virtualization' module.

Apologies if the component is not correct. It seems more like a basesystem or install issue than yast. Regardless, I'm providing the yast logs.
Comment 1 James Fehlig 2019-02-28 18:23:35 UTC
BTW yast2-vm is not installed in Desktop roles either, which is probably fine even though people are running VMs on their workstations, desktops, and laptops. But IMO it should be available in the Server role.
Comment 2 James Fehlig 2019-03-01 16:18:00 UTC
Assigning the bug to a random person that has touched yast2-vm does not help since this is not a yast2-vm problem. I'm asking for yast2-vm package to be included in the Server role.

Maybe we can start with dimstar. If nothing else he can point us in the right direction.
Comment 3 Dominique Leuenberger 2019-03-01 17:18:31 UTC
"Server Role" very wide. It can be a print server, web server VM host, just to name a few.

yast-vm is currently recommended by the kvm_tools pattern.

Since yast2-vm has no hard dependencies on its own which are not already present in the server role, the cost of providing this yast module should be small enough to offer it to everybody. I'll have a look into adjusting the patterns accordingly (enhanced_base would be the pattern of choice for the server role. Of course, this is also the base for desktop environments, where, again, VMs are possibly run, but for not by everybody)
Comment 4 Dominique Leuenberger 2019-06-24 07:40:29 UTC
* Thu Apr 11 2019 Antoine Ginies
- fix installing yast2-vm per default on openSUSE (bsc#1083398)


This issue had been addressed by Antoine