Bug 1127344 - ruby2.6-rubygem-bundler conflicts with ruby2.6
ruby2.6-rubygem-bundler conflicts with ruby2.6
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Ruby
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Marcus Rückert
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-28 11:23 UTC by Markos Chandras
Modified: 2019-02-28 18:06 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras 2019-02-28 11:23:00 UTC
"zypper in ruby2.6-rubygem-bundler" results to

File /usr/bin/bundle.ruby2.6
  from install of
     ruby2.6-rubygem-bundler-1.17.1-1.3.x86_64 (repo-oss)
  conflicts with file from package
     ruby2.6-2.6.1-1.2.x86_64 (@System)

I also tried https://build.opensuse.org/request/show/679516 but the same problem exists.
Comment 1 Ana María Martínez Gómez 2019-02-28 15:01:15 UTC
Why do you want to install ruby2.6-rubygem-bundler? Isn't bundle installed already in Ruby.6 (at least I have bundle and I only have Ruby 2.6 installed)? If that is the case, I would propose to just get rid of ruby2.6-rubygem-bundler and indicate in the Ruby spec that it provides bundle (if it is not done already).

The only thing I needed to get bundle work was a link that Ruby 2.6 is "forgetting":

sudo ln -s /usr/bin/bundle.ruby2.6 /usr/bin/bundle
Comment 2 Markos Chandras 2019-02-28 15:16:02 UTC
(In reply to Ana María Martínez Gómez from comment #1)
> Why do you want to install ruby2.6-rubygem-bundler? Isn't bundle installed
> already in Ruby.6 (at least I have bundle and I only have Ruby 2.6
> installed)? If that is the case, I would propose to just get rid of
> ruby2.6-rubygem-bundler and indicate in the Ruby spec that it provides
> bundle (if it is not done already).
> 
> The only thing I needed to get bundle work was a link that Ruby 2.6 is
> "forgetting":
> 
> sudo ln -s /usr/bin/bundle.ruby2.6 /usr/bin/bundle

Well our current tooling needs the 'bundler' executable and this is only provided by the ruby2.6-rubygem-bundler

~$ cnf bundler
                         
The program 'bundler' can be found in the following package:
  * ruby2.6-rubygem-bundler [ path: /usr/bin/bundler, repository: zypp (repo-oss) ]

Ruby2.6 provides this

~$ rpm -ql ruby2.6|grep /usr/bin/bundler
/usr/bin/bundler.ruby2.6

so if you say both are the same (sorry I do not understand ruby very well) then I am guessing a symlink for bundler is missing?
Comment 3 Marcus Rückert 2019-02-28 15:33:55 UTC
both bugs are fixed with the submission that is pending in staging H

see SR#679514
Comment 4 Ana María Martínez Gómez 2019-02-28 16:07:43 UTC
`/usr/bin/bundler.ruby2.6` is the bundle executable, but the link is missing, so `sudo ln -s /usr/bin/bundle.ruby2.6 /usr/bin/bundle` fixes your problem without having to install ruby2.6-rubygem-bundler :) (this should be fixed though)

Apart from SQ#679514, I think we should drop ruby2.6-rubygem-bundler
Comment 5 Marcus Rückert 2019-02-28 18:06:46 UTC
no we should not. we have all those binaries in update-alternatives that you can install newer versions of the library in parallel. e.g. for bundler there is already version 2.0.0 out.