Bug 1127123 - GCC 9: boost build fails
GCC 9: boost build fails
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Adam Majer
E-mail List
:
Depends on:
Blocks: 1120754
  Show dependency treegraph
 
Reported: 2019-02-27 08:27 UTC by Martin Liška
Modified: 2019-03-08 12:58 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2019-02-27 08:27:10 UTC
Fails here:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:Gcc7/boost/standard/i586

with:
[ 1051s] Conflicts: boost-devel < 1.63 otherproviders(libboost_python-devel)
[ 1051s] Processing files: libboost_numpy-py2_7-1_68_0-1.68.0-4.1.i586
[ 1051s] error: File not found: /home/abuild/rpmbuild/BUILDROOT/boost-1.68.0-4.1.i386/usr/lib/libboost_numpy-py2_7.so.1.68.0
Comment 1 Martin Liška 2019-02-27 08:27:51 UTC
@Adam: Can you please take a look?
Comment 2 Adam Majer 2019-03-07 13:30:46 UTC
It looks like something is wrong with numpy-devel but Boost.Build is so great, it keeps that it keeps that information secret and doesn't tell us what is wrong. And, trying to reproduce the problem locally results in failure to build dependencies,

home:adamm:boost_gcc9_test
Comment 3 Martin Liška 2019-03-07 14:01:46 UTC
I can confirm that on x86_64 openblas fix is not easy and we should probably wait for new release.

On i586, python-numpy is going to finish soon:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:Gcc7/python-numpy/standard/i586

and then you'll be able to:
$ osc co openSUSE:Factory:Staging:Gcc7/boost
$ cd ....
$ osc build
Comment 4 Adam Majer 2019-03-08 12:45:45 UTC
So, looks to be fixed now? Boost seems to build just fine now.
Comment 5 Martin Liška 2019-03-08 12:58:42 UTC
Yes, it's working now.