Bug 1126901 - gnome-terminal-server: SIGSEGV in gdk_x11_device_manager_xi2_translate_event
gnome-terminal-server: SIGSEGV in gdk_x11_device_manager_xi2_translate_event
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-25 19:46 UTC by Pedro Monreal Gonzalez
Modified: 2022-08-23 08:48 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Monreal Gonzalez 2019-02-25 19:46:13 UTC
In gnome-terminal, system freezes for some seconds and then segfaults, reported upstream and not yet fixed:
https://gitlab.gnome.org/GNOME/gtk/issues/855

(gdb) bt
#0  0x00007f99b151a67a in gdk_x11_device_manager_xi2_translate_event (xevent=<optimized out>, event=<optimized out>, display=<optimized out>, translator=<optimized out>) at gdkdevicemanager-xi2.c:1794
#1  0x00007f99b151a67a in gdk_x11_device_manager_xi2_translate_event (translator=<optimized out>, display=<optimized out>, event=<optimized out>, xevent=<optimized out>) at gdkdevicemanager-xi2.c:1478
#2  0x00007f99b15248e8 in _gdk_x11_event_translator_translate (translator=translator@entry=0x560486365000, display=0x5604863410e0 [GdkX11Display], xevent=xevent@entry=0x7ffc65a6c330) at gdkeventtranslator.c:51
#3  0x00007f99b15244c1 in gdk_event_source_translate_event (xevent=0x7ffc65a6c330, event_source=0x56048634c0b0) at gdkeventsource.c:230
#4  0x00007f99b15244c1 in _gdk_x11_display_queue_events (display=0x5604863410e0 [GdkX11Display]) at gdkeventsource.c:341
#5  0x00007f99b14ee950 in gdk_display_get_event (display=display@entry=0x5604863410e0 [GdkX11Display]) at gdkdisplay.c:438
#6  0x00007f99b1524072 in gdk_event_source_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at gdkeventsource.c:363
#7  0x00007f99b1163e2e in g_main_dispatch (context=0x56048637eb10) at gmain.c:3182
#8  0x00007f99b1163e2e in g_main_context_dispatch (context=context@entry=0x56048637eb10) at gmain.c:3847
#9  0x00007f99b11640c8 in g_main_context_iterate (context=context@entry=0x56048637eb10, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3920
#10 0x00007f99b116415c in g_main_context_iteration (context=context@entry=0x56048637eb10, may_block=may_block@entry=1) at gmain.c:3981
#11 0x00007f99b133142d in g_application_run (application=0x56048634e420 [TerminalApp], argc=<optimized out>, argv=0x0) at gapplication.c:2470
#12 0x0000560484ee956c in main (argc=<optimized out>, argv=<optimized out>) at server.c:187
Comment 1 Pedro Monreal Gonzalez 2022-08-23 08:48:43 UTC
Could not reproduce for a long time.