Bug 1126868 - Resolving package dependencies for Python ABI 3.7 (because of Meson 0.49.1)
Resolving package dependencies for Python ABI 3.7 (because of Meson 0.49.1)
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
x86-64 SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-25 17:05 UTC by Markus Elfring
Modified: 2021-09-14 06:39 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Elfring 2019-02-25 17:05:49 UTC
I would like to build specific components also for GNOME software configurations.
Thus I would need to install required software by a tool like “JHBuild”.
One of these requirements is an evolving build system generator.

Sonne:~ # zypper in meson            
…
Resolving package dependencies...

Problem: meson-0.49.1-1.1.noarch requires python(abi) = 3.7, but this requirement cannot be provided
  not installable providers: python3-base-3.7.2-2.2.i586[Steppenläufer]
                   python3-base-3.7.2-2.2.x86_64[Steppenläufer]
…


How long will it take to get these dependencies consistent again?
Comment 1 Dominique Leuenberger 2021-09-14 06:39:12 UTC
meson has since grown to a first class build system, even used in the distro bootstrap packages to get built. So we can be rather sure to have an always working meson now.

(sorrt for the long delay in this bug report)