Bug 1126817 - GCC 9: libqt5-qtbase build fails
GCC 9: libqt5-qtbase build fails
Status: RESOLVED DUPLICATE of bug 1121561
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks: 1120754
  Show dependency treegraph
 
Reported: 2019-02-25 14:30 UTC by Martin Liška
Modified: 2019-02-25 14:30 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2019-02-25 14:30:07 UTC
Fails here:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:Gcc7/libqt5-qtbase/standard/i586

with:

[   94s] /home/abuild/rpmbuild/BUILD/qtbase-everywhere-src-5.12.0/src/corelib/global/qrandom.cpp: In static member function 'static void QRandomGenerator::SystemAndGlobalGenerators::securelySeed(QRandomGenerator*)':
[   95s] /home/abuild/rpmbuild/BUILD/qtbase-everywhere-src-5.12.0/src/corelib/global/qrandom.cpp:455:62: error: no matching function for call to 'std::mersenne_twister_engine<unsigned int, 32, 624, 397, 31, 2567483615, 11, 4294967295, 7, 2636928640, 15, 4022730752, 18, 1812433253>::mersenne_twister_engine(QRandomGenerator::SystemGenerator&)'
[   95s]   455 |         new (&rng->storage.engine()) RandomEngine(self()->sys);
[   95s]       |                                                              ^
[   95s] In file included from /usr/include/c++/9/random:49,
[   95s]                  from /home/abuild/rpmbuild/BUILD/qtbase-everywhere-src-5.12.0/src/corelib/global/qrandom.h:45,
[   95s]                  from /home/abuild/rpmbuild/BUILD/qtbase-everywhere-src-5.12.0/src/corelib/global/qrandom.cpp:43:
[   95s] /usr/include/c++/9/bits/random.h:530:9: note: candidate: 'template<class _Sseq, class> std::mersenne_twister_engine<_UIntType, __w, __n, __m, __r, __a, __u, __d, __s, __b, __t, __c, __l, __f>::mersenne_twister_engine(_Sseq&)'
[   95s]   530 |         mersenne_twister_engine(_Sseq& __q)
[   95s]       |         ^~~~~~~~~~~~~~~~~~~~~~~
[   95s] /usr/include/c++/9/bits/random.h:530:9: note:   template argument deduction/substitution failed:
[   95s] /usr/include/c++/9/bits/random.h:519:7: note: candidate: 'std::mersenne_twister_engine<_UIntType, __w, __n, __m, __r, __a, __u, __d, __s, __b, __t, __c, __l, __f>::mersenne_twister_engine(std::mersenne_twister_engine<_UIntType, __w, __n, __m, __r, __a, __u, __d, __s, __b, __t, __c, __l, __f>::result_type) [with _UIntType = unsigned int; unsigned int __w = 32; unsigned int __n = 624; unsigned int __m = 397; unsigned int __r = 31; _UIntType __a = 2567483615; unsigned int __u = 11; _UIntType __d = 4294967295; unsigned int __s = 7; _UIntType __b = 2636928640; unsigned int __t = 15; _UIntType __c = 4022730752; unsigned int __l = 18; _UIntType __f = 1812433253; std::mersenne_twister_engine<_UIntType, __w, __n, __m, __r, __a, __u, __d, __s, __b, __t, __c, __l, __f>::result_type = unsigned int]'
Comment 1 Martin Liška 2019-02-25 14:30:58 UTC
Dup.

*** This bug has been marked as a duplicate of bug 1121561 ***