Bug 1125813 - Firefox, 100% CPU load on all cores, for ~20 seconds, every minute, removing ~/.fonts
Firefox, 100% CPU load on all cores, for ~20 seconds, every minute, removing...
Status: RESOLVED DUPLICATE of bug 1124816
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-18 16:08 UTC by Michael Traxler
Modified: 2019-02-19 00:56 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Traxler 2019-02-18 16:08:59 UTC
When running Firefox on the newest Tumbleweed from time to time (~1 minute time spans) the firefox threads go to 100% CPU load and you can not open new tabs in firefox, for some time. The time of blocking is dependent on the number of fonts you have installed and you can see with strace that firefox goes in a loop opening all installed fonts.
A workaround for me was to remove .fonts.

The solution I found here:
https://askubuntu.com/questions/1076412/firefox-freezing-with-100-cpu-usage-for-30-seconds-when-launching-chromium
Comment 1 Frank Krüger 2019-02-18 19:36:57 UTC
(In reply to Michael Traxler from comment #0)
> When running Firefox on the newest Tumbleweed from time to time (~1 minute
> time spans) the firefox threads go to 100% CPU load and you can not open new
> tabs in firefox, for some time. The time of blocking is dependent on the
> number of fonts you have installed and you can see with strace that firefox
> goes in a loop opening all installed fonts.
> A workaround for me was to remove .fonts.
> 
> The solution I found here:
> https://askubuntu.com/questions/1076412/firefox-freezing-with-100-cpu-usage-
> for-30-seconds-when-launching-chromium

Probably a duplicate of https://bugzilla.suse.com/show_bug.cgi?id=1124816. A fix seems to be on the way: https://build.opensuse.org/request/show/673056.
Comment 2 Atri Bhattacharya 2019-02-19 00:56:36 UTC
Please reopen if fontconfig package from M17N (https://build.opensuse.org/package/show/M17N/fontconfig) does not help.

*** This bug has been marked as a duplicate of bug 1124816 ***