Bug 1125790 - GCC 9: python-pyside-shiboken build fails
GCC 9: python-pyside-shiboken build fails
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ferdinand Thiessen
E-mail List
:
Depends on:
Blocks: 1120754
  Show dependency treegraph
 
Reported: 2019-02-18 14:19 UTC by Martin Liška
Modified: 2019-04-29 13:49 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2019-02-18 14:19:14 UTC
Build fails with GCC 9 due to:

    bool argumentsHaveNativeId() const
    {
        
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h" 3
       for (QForeachContainer<__typeof__(
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h"
       m_arguments
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h" 3
       )> _container_(
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h"
       m_arguments
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h" 3
       ); !_container_.brk && _container_.i != _container_.e; __extension__ ({ ++_container_.brk; ++_container_.i; })) for (
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h"
       const AbstractMetaArgument *arg 
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h" 3
       = *_container_.i;; __extension__ ({--_container_.brk; break;})) 
# 921 "/home/abuild/rpmbuild/BUILD/Shiboken-1.2.4/ApiExtractor/abstractmetalang.h"
                                                              {
            if (arg->type()->hasNativeId())
                return true;
        }

        return false;
    }

which is dropped here:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=44715
Comment 1 Martin Liška 2019-04-12 08:34:25 UTC
@Ferdinand: Can you please take a look?
Comment 2 Martin Liška 2019-04-25 10:53:04 UTC
(In reply to Martin Liška from comment #1)
> @Ferdinand: Can you please take a look?

May I please remind this?
Comment 3 Martin Liška 2019-04-29 13:49:04 UTC
The package has been removed, thus closing.