Bug 1125785 - [Build 20190217] openQA test fails in machinery, no machinery-helper available for the remote system architecture aarch64
[Build 20190217] openQA test fails in machinery, no machinery-helper availabl...
Status: VERIFIED FIXED
: 1125398 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
aarch64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Tim Hardeck
E-mail List
https://openqa.opensuse.org/tests/857...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-18 14:07 UTC by Guillaume GARDET
Modified: 2019-08-22 07:45 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume GARDET 2019-02-18 14:07:32 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-extra_tests_in_textmode@aarch64 fails in
[machinery](https://openqa.opensuse.org/tests/857314/modules/machinery/steps/18)

## Test suite description
Maintainer: okurz@suse.de

Mainly console extratest.


## Reproducible

Fails since (at least) Build [20181018](https://openqa.opensuse.org/tests/778961)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?test=extra_tests_in_textmode&arch=aarch64&version=Tumbleweed&flavor=DVD&distri=opensuse&machine=aarch64)
Comment 1 Guillaume GARDET 2019-02-18 14:07:59 UTC
Same error seen on ppc64: https://bugzilla.opensuse.org/show_bug.cgi?id=1125398
Comment 2 Tim Hardeck 2019-02-20 14:52:51 UTC
Thanks for the report and thanks for adding machinery to openQA.

Can we disable the tests for this architecture? Support would be possible of course (we just need to add the architecture) but we would need a new release, testing and so on.

Is there anybody interested in this or is this just full coverage testing?
Comment 3 Guillaume GARDET 2019-02-20 15:07:33 UTC
(In reply to Tim Hardeck from comment #2)
> Thanks for the report and thanks for adding machinery to openQA.
> 
> Can we disable the tests for this architecture? Support would be possible of
> course (we just need to add the architecture) but we would need a new
> release, testing and so on.
> 
> Is there anybody interested in this or is this just full coverage testing?

As machinery is available on aarch64 (and ppc64), it make sense to make it fully functional and fix this problem. 

I may help if needed.
Comment 4 Guillaume GARDET 2019-02-20 15:14:24 UTC
btw, in build log there is:
[   85s] Building machinery-helper for architecture i686.
[   95s] Building machinery-helper for architecture x86_64.
[  108s] Building machinery-helper for architecture ppc64le.
[  120s] Building machinery-helper for architecture ppc64.
[  133s] Building machinery-helper for architecture s390x.
[  146s] Building machinery-helper for architecture armv6l.
[  158s] Building machinery-helper for architecture armv7l.
[  172s] Building machinery-helper for architecture aarch64.
Comment 5 Guillaume GARDET 2019-02-20 15:19:12 UTC
(In reply to Guillaume GARDET from comment #4)
> btw, in build log there is:
> [   85s] Building machinery-helper for architecture i686.
> [   95s] Building machinery-helper for architecture x86_64.
> [  108s] Building machinery-helper for architecture ppc64le.
> [  120s] Building machinery-helper for architecture ppc64.
> [  133s] Building machinery-helper for architecture s390x.
> [  146s] Building machinery-helper for architecture armv6l.
> [  158s] Building machinery-helper for architecture armv7l.
> [  172s] Building machinery-helper for architecture aarch64.

This log is from Leap:15.1:ARM, not Factory:ARM.
Comment 6 Tim Hardeck 2019-02-20 15:39:28 UTC
Thanks, technically it is no problem, and I can fix it easily, just need to add it to the supported architectures and add the matching golang arch.

We are not working on machinery since quite some time so we would need to shift resources.

The problem is that the whole process behind releasing (especially to SLE) is a little bigger and we would in theory need to do QA for these architectures, adapt our automated tests and so on.

There are also other issues in Tumbleweed which would needed to be fixed like the image building which is not so trivial. It needs support for current Kiwi version.

If you are only interested in getting these two architectures supported on Tumbleweed I can fix it and create a release if you like.
Comment 7 Guillaume GARDET 2019-02-20 16:13:32 UTC
(In reply to Tim Hardeck from comment #6)
> If you are only interested in getting these two architectures supported on
> Tumbleweed I can fix it and create a release if you like.

Yes, please. :)
Comment 8 Michel Normand 2019-02-21 14:05:03 UTC
*** Bug 1125398 has been marked as a duplicate of this bug. ***
Comment 11 Guillaume GARDET 2019-05-09 07:48:04 UTC
Any progress on this bug?
Comment 12 Michel Normand 2019-05-09 08:11:25 UTC
(In reply to Guillaume GARDET from comment #11)
> Any progress on this bug?

as a bypass may be interesting to do same as for ppc64le: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7323
Comment 13 Tim Hardeck 2019-05-09 08:36:02 UTC
(In reply to Guillaume GARDET from comment #11)
> Any progress on this bug?

Sadly no, we do not have the resources to work on it at the moment.

Just adding the few lines is not the problem, but we should not do a hackish release without updating our integration tests and fixing bigger issues like the Kiwi support.

If there is a customer complaining about this missing feature it might be a different case but I can not decide that.
Comment 17 Tim Hardeck 2019-06-28 13:25:59 UTC
I have fixed this issue besides others during Hackweek and will try to release a new version of Machinery to Tumbleweed soon.

So we were supporting both archs already, but there was an issue in parsing of the latest go version.
Comment 18 Tim Hardeck 2019-07-02 14:01:15 UTC
This issue should be fixed as soon as https://build.opensuse.org/request/show/713068 is accepted.
Comment 19 Swamp Workflow Management 2019-07-03 14:10:07 UTC
This is an autogenerated message for OBS integration:
This bug (1125785) was mentioned in
https://build.opensuse.org/request/show/713248 Factory / machinery
Comment 20 Swamp Workflow Management 2019-07-03 14:50:06 UTC
This is an autogenerated message for OBS integration:
This bug (1125785) was mentioned in
https://build.opensuse.org/request/show/713252 Factory / machinery
Comment 21 Michel Normand 2019-07-04 09:25:13 UTC
FYI:
as per snapshot 20190703, unable to validate as machinery package install failed with missing rubygem(ruby:2.6.0:kramdown) needed by machinery-1.23.1-1.8
https://openqa.opensuse.org/tests/975066#step/machinery/2 <= ppc64le
https://openqa.opensuse.org/tests/974955#step/machinery/2 <= x86_64

I assume we have to wait new ruby:2.6.0 in Factory.
Comment 22 Swamp Workflow Management 2019-07-04 15:10:06 UTC
This is an autogenerated message for OBS integration:
This bug (1125785) was mentioned in
https://build.opensuse.org/request/show/713443 15.0 / machinery
Comment 23 Swamp Workflow Management 2019-07-05 08:30:07 UTC
This is an autogenerated message for OBS integration:
This bug (1125785) was mentioned in
https://build.opensuse.org/request/show/713563 15.1 / machinery
Comment 24 Tim Hardeck 2019-07-05 10:55:52 UTC
Thanks for your quick feedback.

Machinery 1.23.1 is still the old version. The kramdown issue was also fixed in 1.24.1. The submit request was accepted so the package should be available in Tumbleweed soon.
Comment 25 Tim Hardeck 2019-07-08 15:04:17 UTC
Machinery 1.24.1 is now available in Tumbleweed.
The issue should be fixed. Is openQA reporting back automatically or are any manual steps needed?
Comment 26 Dominik Heidler 2019-07-09 11:20:00 UTC
See https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7834 for verification.

It seems to work fine - at least with that fix for the testsuite.
Comment 27 Tim Hardeck 2019-07-15 09:15:49 UTC
This should be fixed with Machinery 1.24.1.
Please reopen if the issue still appears but building of ppc64le and aarch64 machinery-helper modules should be possible and also inspection of those architectures.
Comment 28 Swamp Workflow Management 2019-07-21 10:11:42 UTC
openSUSE-RU-2019:1765-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1125785
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    machinery-1.24.1-lp151.3.3.1
openSUSE Leap 15.0 (src):    machinery-1.24.1-lp150.2.3.1
Comment 29 Swamp Workflow Management 2019-07-22 10:15:35 UTC
openSUSE-RU-2019:1787-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1125785
CVE References: 
Sources used:
openSUSE Backports SLE-15 (src):    machinery-1.24.1-bp150.3.3.1
Comment 30 Swamp Workflow Management 2019-08-14 16:17:49 UTC
openSUSE-RU-2019:1885-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1125785
CVE References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    machinery-1.24.1-bp151.4.3.1
Comment 31 Dominik Heidler 2019-08-22 07:45:22 UTC
Works in TW 20190820:
https://openqa.opensuse.org/tests/1013153#step/machinery/18