Bug 1125772 - GCC 9: autogen build fails
GCC 9: autogen build fails
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Liška
E-mail List
:
Depends on:
Blocks: 1120754
  Show dependency treegraph
 
Reported: 2019-02-18 12:25 UTC by Martin Liška
Modified: 2019-03-26 05:54 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2019-02-18 12:25:57 UTC
Using GCC 9 one can see:

$ /bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -I.. -I../autoopts  -DPKGDATADIR='"/usr/local/share/autogen"' -g -O2 -Wno-format-contains-nul -fno-strict-aliasing -Wall -Werror -Wcast-align -Wmissing-prototypes -Wpointer-arith -Wshadow -Wstrict-prototypes -Wwrite-strings -Wstrict-aliasing=3 -Wextra -Wno-cast-qual -g -O2 -Wno-format-contains-nul -fno-strict-aliasing -c -o libopts_la-libopts.lo `test -f 'libopts.c' || echo './'`libopts.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I../autoopts -DPKGDATADIR=\"/usr/local/share/autogen\" -g -O2 -Wno-format-contains-nul -fno-strict-aliasing -Wall -Werror -Wcast-align -Wmissing-prototypes -Wpointer-arith -Wshadow -Wstrict-prototypes -Wwrite-strings -Wstrict-aliasing=3 -Wextra -Wno-cast-qual -g -O2 -Wno-format-contains-nul -fno-strict-aliasing -c libopts.c  -fPIC -DPIC -o .libs/libopts_la-libopts.o
In file included from autoopts.c:42,
                 from libopts.c:22:
In function ‘canonicalize_pathname’,
    inlined from ‘option_pathfind.constprop’ at ../compat/pathfind.c:88:32:
../compat/pathfind.c:214:17: error: ‘strcpy’ accessing 1 byte at offsets [0, 9223372036854775807] and [0, 9223372036854775807] may overlap 1 byte at offset 0 [-Werror=restrict]
  214 |                 strcpy( result + start + 1, result + i + 2 );
      |                 ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

It's analyzed here:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88973

and it looks it's a real issue.
Comment 1 Andreas Schwab 2019-02-19 08:49:52 UTC
Have you tried reporting it to <https://sourceforge.net/p/autogen/bugs/>?
Comment 2 Martin Liška 2019-02-19 09:35:28 UTC
(In reply to Andreas Schwab from comment #1)
> Have you tried reporting it to <https://sourceforge.net/p/autogen/bugs/>?

Done:
https://sourceforge.net/p/autogen/bugs/193/
Comment 3 Martin Liška 2019-02-20 11:54:07 UTC
Patch candidate has been sent:
https://sourceforge.net/p/autogen/bugs/193/#5844
Comment 4 Martin Liška 2019-03-25 08:33:23 UTC
SR: https://build.opensuse.org/request/show/688130
Comment 5 Swamp Workflow Management 2019-03-25 17:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1125772) was mentioned in
https://build.opensuse.org/request/show/688388 Factory / autogen
Comment 6 Martin Liška 2019-03-26 05:54:47 UTC
Closing as fixed.