Bug 1125667 - hplip: hp-setup dumps core
hplip: hp-setup dumps core
Status: RESOLVED DUPLICATE of bug 1107711
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Printing
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Johannes Meixner
Johannes Meixner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-16 17:51 UTC by Klaus Kämpf
Modified: 2019-08-12 12:17 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Kämpf 2019-02-16 17:51:35 UTC
CPE_NAME="cpe:/o:opensuse:tumbleweed:20190209"

> hp-setup 

HP Linux Imaging and Printing System (ver. 3.18.6)
Printer/Fax Setup Utility ver. 9.0
...
Traceback (most recent call last):
  File "/usr/share/hplip/ui5/setupdialog.py", line 1305, in NextButton_clicked
    self.showAddPrinterPage()
  File "/usr/share/hplip/ui5/setupdialog.py", line 729, in showAddPrinterPage
    self.readwriteFaxInformation()
  File "/usr/share/hplip/ui5/setupdialog.py", line 1128, in readwriteFaxInformation
    self.fax_number = to_unicode(d.getPhoneNum())
  File "/usr/share/hplip/fax/pmlfax.py", line 146, in getPhoneNum
    data = utils.printable(self.getPML(pml.OID_FAX_LOCAL_PHONE_NUM)[1])
  File "/usr/share/hplip/base/utils.py", line 957, in printable
    return s.translate(identity, unprintable)
TypeError: translate() takes exactly one argument (2 given)
Aborted (core dumped)
Comment 1 Ferdinand Thiessen 2019-08-12 12:17:10 UTC
Same as 1107711, there are also more information on how to fix.

*** This bug has been marked as a duplicate of bug 1107711 ***