Bug 1125542 - [Build 20190214] python-qt4 build failure stops zdup process
[Build 20190214] python-qt4 build failure stops zdup process
Status: RESOLVED FIXED
: 1125636 1125691 1127435 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal with 5 votes (vote)
: ---
Assigned To: Dirk Mueller
E-mail List
https://openqa.opensuse.org/tests/854...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-15 07:45 UTC by Dominique Leuenberger
Modified: 2019-03-01 19:40 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-02-15 07:45:54 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-13.2@64bit fails in
[zdup](https://openq

## Test suite description



## Reproducible

Fails since (at least) Build [20190202](https://openqa.opensuse.org/tests/845590)


## Expected result

Last good: [20190201](https://openqa.opensuse.org/tests/845046) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?test=zdup-13.2&arch=x86_64&version=Tumbleweed&flavor=NET&distri=opensuse&machine=64bit)


The root cause for this openQA failure is python-qt4 build failure after the upgrade of python-sip.
Comment 1 Dominique Leuenberger 2019-02-15 08:15:02 UTC
[  111s] g++ -c -pipe -fno-exceptions -g -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_PLUGIN -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/default -I. -I/usr/include/QtCore -I/usr/include -I. -I/usr/include/python2.7 -I../../qpy/QtCore -I. -o sipQtCoreQAbstractItemModel.o sipQtCoreQAbstractItemModel.cpp
[  113s] /home/abuild/rpmbuild/BUILD/PyQt4_gpl_x11-4.12.3/build_2.7/QtCore/sipQtCoreQAbstractAnimation.cpp:1076:1: error: cannot convert 'std::nullptr_t' to 'int' in initialization
[  113s]  };
[  113s]  ^
[  113s] /home/abuild/rpmbuild/BUILD/PyQt4_gpl_x11-4.12.3/build_2.7/QtCore/sipQtCoreQAbstractEventDispatcher.cpp:1167:1: error: cannot convert 'std::nullptr_t' to 'int' in initialization
[  113s]          sipNameNr_QAbstractEventDispatcher,
[  113s]  ^
[  113s] /home/abuild/rpmbuild/BUILD/PyQt4_gpl_x11-4.12.3/build_2.7/QtCore/sipQtCoreQAbstractItemModel.cpp:3036:1: error: cannot convert 'std::nullptr_t' to 'int' in initialization
[  113s]      SIP_NULLPTR,
[  113s]  ^
Comment 2 Wolfgang Bauer 2019-02-16 07:10:08 UTC
*** Bug 1125636 has been marked as a duplicate of this bug. ***
Comment 3 Wolfgang Bauer 2019-02-16 20:07:34 UTC
JFYI, I managed to build python-qt4 by adding "-std=c++98" to the compiler flags.
I.e. something like:
diff -u a/configure-ng.py b/configure-ng.py 
--- a/configure-ng.py
+++ b/configure-ng.py
@@ -2400,7 +2400,7 @@
             spec = 'macx-g++'
 
     if 'g++' in spec or 'clang' in spec:
-        pro_lines.append('QMAKE_CXXFLAGS += -fno-exceptions')
+        pro_lines.append('QMAKE_CXXFLAGS += -fno-exceptions -std=c++98')
 
     # This optimisation could apply to other platforms.
     if 'linux' in spec and not target_config.static:

That would IME make it necessary to compile all depending packages with "-std-c++98" as well though (because the generated code requires it), so not a proper fix I think.
Comment 4 Wolfgang Bauer 2019-02-20 08:59:23 UTC
*** Bug 1125691 has been marked as a duplicate of this bug. ***
Comment 5 Jon Brightwell 2019-02-20 13:51:22 UTC
This is still outstanding and has now hit tumbleweed

4 Problems:
Problem: python2-qt4-4.12.3-1.3.x86_64 requires python2-sip(api) = 12.5, but this requirement cannot be provided
Problem: python3-qt4-4.12.3-1.3.x86_64 requires python3-sip(api) = 12.5, but this requirement cannot be provided
Problem: python2-sip-4.19.13-2.3.x86_64 requires python2-sip-common = 4.19.13, but this requirement cannot be provided
Problem: python3-qt4-4.12.3-1.3.x86_64 requires python3-sip(api) = 12.5, but this requirement cannot be provided
Comment 6 Wolfgang Bauer 2019-02-22 06:39:16 UTC
A fix (from upstream) is on the way to Tumbleweed:
https://build.opensuse.org/request/show/678047
Comment 7 Frank Krüger 2019-02-22 20:01:38 UTC
(In reply to Wolfgang Bauer from comment #6)
> A fix (from upstream) is on the way to Tumbleweed:
> https://build.opensuse.org/request/show/678047

Works for me. Thx.
Comment 8 patrick shanahan 2019-02-22 20:22:56 UTC
and works for me, tks
Comment 9 Wolfgang Bauer 2019-03-01 06:13:53 UTC
*** Bug 1127435 has been marked as a duplicate of this bug. ***
Comment 10 Wolfgang Bauer 2019-03-01 06:17:05 UTC
The updated python-sip is in Factory since yesterday, but python-qt4 has not been rebuilt yet.
It would probably need a manual trigger...
Comment 11 Wolfgang Bauer 2019-03-01 19:40:58 UTC
python-qt4 built successfully in Factory meanwhile, and the "zdup" test passed as well again:
https://openqa.opensuse.org/tests/865963

So I'll close this.

The conflict should be gone in the next TW snapshot.