Bug 1124397 - open-vm-tools: Correct and/or improve handling of certain quiesced snapshot failures.
open-vm-tools: Correct and/or improve handling of certain quiesced snapshot f...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Virtualization:Tools
Leap 42.3
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Kirk Allan
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-02-05 22:04 UTC by Oliver Kurth
Modified: 2019-05-21 06:04 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurth 2019-02-05 22:04:24 UTC
Customers may hit issues with quiesced snapshots under certain circumstances. This is fixed in a branch forked from 10.3.5:

https://github.com/vmware/open-vm-tools/tree/stable-10.3.5-quiesced-snapshot

A more detailed description of the issue can be found in the individual commit messages.
Comment 1 Oliver Kurth 2019-02-06 01:43:15 UTC
A short summary of the changes:

- Attempt to notify the host that a backup manifest is available on every completed snapshot. Previously vmtoolsd attempted to detect whether the host was running an older version of ESX that did not support receiving a backup manifest, which occasionally resulted in it erroneously identifying a host as an older host.
- Provide more informative logging messages when a backup manifest notification is refused by the host.
- Abort quiesced snapshot operations promptly after detecting that the host has aborted its side of the operation. Previously vmtools would continue until it hit its own internal timeout.
- Don’t try to notify the host that a backup manifest is available when the quiesced snapshot is aborted.

We suggest to have these changes integrated into the 10.3.5 package.
Comment 4 Kirk Allan 2019-02-12 17:36:39 UTC
The changes have been submitted.  Waiting for acceptance.
Comment 6 Swamp Workflow Management 2019-03-20 17:15:12 UTC
SUSE-RU-2019:0667-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP4 (src):    open-vm-tools-10.3.5-4.3.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    open-vm-tools-10.3.5-4.3.1
Comment 7 Swamp Workflow Management 2019-03-21 23:21:24 UTC
SUSE-RU-2019:0696-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP3 (src):    open-vm-tools-10.3.5-3.22.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    open-vm-tools-10.3.5-3.22.1
SUSE CaaS Platform ALL (src):    open-vm-tools-10.3.5-3.22.1
SUSE CaaS Platform 3.0 (src):    open-vm-tools-10.3.5-3.22.1
Comment 8 Swamp Workflow Management 2019-03-29 14:11:50 UTC
openSUSE-RU-2019:1078-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    open-vm-tools-10.3.5-22.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2019-04-01 22:10:28 UTC
SUSE-RU-2019:14006-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1124397
CVE References: 
Sources used:
SUSE Linux Enterprise Server 11-SP4 (src):    open-vm-tools-10.3.5-8.12.2
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    open-vm-tools-10.3.5-8.12.2

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 11 Kirk Allan 2019-04-04 15:12:53 UTC
The fix is now available for install.  Marking as fixed.
Comment 12 Swamp Workflow Management 2019-04-05 05:29:10 UTC
openSUSE-RU-2019:1102-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,
1121964,1122435,1124397,1126102
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    open-vm-tools-10.3.5-lp150.2.10.2, xmlsec1-1.2.26-lp150.7.2

*** NOTE: This information is n
ot intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2019-04-10 15:05:47 UTC
openSUSE-RU-2019:1102-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,
1121964,1122435,1124397,1126102
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    open-vm-tools-10.3.5-lp150.2.10.2, xmlsec1-1.2.26-lp150.7.2

*** NOTE: This information is n
ot intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 14 Swamp Workflow Management 2019-05-21 06:04:55 UTC
openSUSE-RU-2019:1102-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397,1126102
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    open-vm-tools-10.3.5-lp150.2.10.2, xmlsec1-1.2.26-lp150.7.2

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.