Bug 1123334 - (CVE-2018-20743) VUL-1: CVE-2018-20743: mumble: instability and crash due to crafted message flooding
(CVE-2018-20743)
VUL-1: CVE-2018-20743: mumble: instability and crash due to crafted message f...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.1
Other Other
: P4 - Low : Minor (vote)
: ---
Assigned To: Marguerite Su
Security Team bot
https://smash.suse.de/issue/223800/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-28 10:40 UTC by Karol Babioch
Modified: 2020-01-29 23:38 UTC (History)
6 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2019-01-28 10:40:17 UTC
CVE-2018-20743

murmur in Mumble through 1.2.19 before 2018-08-31 mishandles multiple concurrent
requests that are persisted in the database, which allows remote attackers to
cause a denial of service (daemon hang or crash) via a message flood.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-20743
https://bugs.debian.org/919249
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-20743.html
https://github.com/mumble-voip/mumble/issues/3505
https://github.com/mumble-voip/mumble/pull/3510
https://github.com/mumble-voip/mumble/pull/3512
Comment 1 Tomáš Chvátal 2019-07-11 11:38:42 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 3 Swamp Workflow Management 2019-07-14 14:10:07 UTC
This is an autogenerated message for OBS integration:
This bug (1123334) was mentioned in
https://build.opensuse.org/request/show/715323 15.0+15.1+Backports:SLE-12+Backports:SLE-15 / mumble
Comment 4 Ferdinand Thiessen 2019-07-14 15:23:42 UTC
Added patches from upstream to the package (they had to be backported), already done for the development package, submit requests to the various distributions:

Factory: https://build.opensuse.org/request/show/715233
Leap / SLE: https://build.opensuse.org/request/show/715323
Comment 5 Ferdinand Thiessen 2019-07-18 22:05:44 UTC
Bugfix update is requesting release:
https://build.opensuse.org/request/show/715937
Comment 6 Swamp Workflow Management 2019-07-23 16:12:27 UTC
openSUSE-SU-2019:1794-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1123334
CVE References: CVE-2018-20743
Sources used:
openSUSE Leap 15.1 (src):    mumble-1.2.19-lp151.4.6.1
openSUSE Leap 15.0 (src):    mumble-1.2.19-lp150.3.3.1
openSUSE Backports SLE-15 (src):    mumble-1.2.19-bp150.3.3.1
Comment 7 Swamp Workflow Management 2019-07-23 16:16:35 UTC
openSUSE-SU-2019:1794-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1123334
CVE References: CVE-2018-20743
Sources used:
openSUSE Leap 15.1 (src):    mumble-1.2.19-lp151.4.6.1
openSUSE Leap 15.0 (src):    mumble-1.2.19-lp150.3.3.1
openSUSE Backports SLE-15 (src):    mumble-1.2.19-bp150.3.3.1
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    mumble-1.2.19-9.1
Comment 8 Swamp Workflow Management 2019-08-14 13:13:03 UTC
openSUSE-SU-2019:1876-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1123334
CVE References: CVE-2018-20743
Sources used:
openSUSE Backports SLE-15-SP1 (src):    mumble-1.2.19-bp151.6.3.1
Comment 9 Swamp Workflow Management 2020-01-29 20:31:27 UTC
openSUSE-SU-2020:0137-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1123334
CVE References: CVE-2018-20743
Sources used:
openSUSE Backports SLE-15-SP1 (src):    mumble-1.2.19-bp151.6.6.1